Анна гутлина
?>

1. написать программу, массив из 10 случайных целых чисел из отрезка [-50; 50]. вывести на экран весь массив и на отдельной строке — значение минимального элемента массива.​

Информатика

Ответы

superniki87

Відповідь:

1) 20; 2) 90; 3) 4; 4) 16; 5) 3; 6) 6

Пояснення:

1) 157_{8\\ }= \\1*8^2+5*8^1+7*8^0=1*64+8*5+7*1=64+40+7=111

84_{16\\ }=8*16^1+4*16^0=8*16+4*1=128+4=132

Натуральных чисел 111<X<132

132-111-1=20

2) 104_{8\\ }=1*8^2+0*8^1+4*8^0=1*16+0+4*1=16+0+4=20

6F_{16\\ }=6*16^1+15*16^0=96+15=111

Натуральных чисел 20<X<111

111-20-1=90

3) 113_{8\\ }=1*8^2+1*8^1+3*8^0=1*64+1*8+3*1=64+8+3=75

54_{16\\ }=5*16^1+4*16^0=5*16+4*1=80+4=84

Натуральных чисел 75<X<80

80-75-1=4

4) 132_{8\\ }=1*8^2+3*8^1+2*8^0=1*64+3*8+2*1=64+24+2=90

6B_{16\\ }=6*16^1+11*16^0=6*16+11=107

Натуральных чисел 90<X<107

107-90-1=16

5) 53_{16\\ }=5*16^1+3*16^0=5*16+3*1=80+3=83

127_{8\\ }=1*8^2+2*8^1+7*8^0=1*64+2*8+7*1=64+16+7=87

Натуральных чисел 83<X<87

87-83-1=3

6) 7F_{16\\ }=7*16^1+15*16^0=112+15=127

206_{8\\ }=2*8^2+0*8^1+6*8^0=2*64+0*8+6*1=128+0+6=134

Натуральных чисел 127<X<134

134-127-1=6

Попова1271

решение, что называется, "в лоб"

var s,k1,k5,k10,k50,k100,k500,k1000,k10000: integer;

begin

write('s = '); readln(s);

k1: =0; k5: =0; k10: =0; k50: =0;  

k100: =0; k500: =0; k1000: =0; k10000: =0;

while s> =10000 do begin s: =s-10000; k10000: =k10000+1; end;

while s> =1000 do begin s: =s-1000; k1000: =k1000+1; end;

while s> =500 do begin s: =s-500; k500: =k500+1; end;

while s> =100 do begin s: =s-100; k100: =k100+1; end;

while s> =50 do begin s: =s-50; k50: =k50+1; end;

while s> =10 do begin s: =s-10; k10: =k10+1; end;

while s> =5 do begin s: =s-5; k5: =k5+1; end;

while s> =1 do begin s: =s-1; k1: =k1+1; end;

writeln('k10000=',k10000,' k1000=',k1000,' k500=',k500,' k100=',k100,' k50=',k50,' k10=',k10,' k5=',k5,' k1=',k1);

writeln(' всего купюр = ',k1+k5+k10+k50+k100+k500+k1000+k10000);

end.

подробнее - на -

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1. написать программу, массив из 10 случайных целых чисел из отрезка [-50; 50]. вывести на экран весь массив и на отдельной строке — значение минимального элемента массива.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

webotryvclub21
kav511
o-pavlova-8635
kizyaev6651
Titeeva-Vladimirovich283
Ligaevruslan
hrviko
brand
Владимирович_Роман
игнатова_Сергей1228
marketing601
jstepanova
mos-5nica
Mariya dmitrievna
Vrpeshka