iptsr4968
?>

Впаскаль abc написать программу, которая с процедуры меняет значения переменных a, b, c так, чтобы они были расположены в порядке возрастания

Информатика

Ответы

likakedo4ka439

количество информации i, которое несет сообщение о реализация события a равно -ln(p), где p - вероятность события a.

 

xкр = 27 - количество семян круглой редиски xвыт - количество семян плоской редискиpвыт - вероятность достать семечко вытянутой редиски равно xвыт/(xкр+xвыт)

i - количество информации, которое несет сообщение о том, что доставли одно семечко вытянутой редиски

исходя из условий , можем составить уравнение: i = -ln(xвыт/(xкр+xвыт)) -> 2^-2 = xвыт/(xкр+xвыт), откуда получаем xвыт = 9общее количесво семян равно (xвыт + xкр) = 36

komarov-dmitriy

Вот пример написанный на С++

Если нужно объяснить программу то пиши: Telegram @danileremeev

#include <iostream>

using namespace std;

struct st{

int x1, x2, x3, amount, composition, sum_of_squares;

int number, thousand, hundreds, dozens, units;

int a, b, amount_ab, difference_ab, composition_ab;

}; st St;

int main() {

setlocale(0, "");

cout << "1)\n";

cout << "x1: "; cin >> St.x1;

cout << "x2: "; cin >> St.x2;

cout << "x2: "; cin >> St.x3;

St.amount = St.x1 + St.x2 + St.x3;

St.composition = St.x1 * St.x2 * St.x3;

St.sum_of_squares = (St.x1 * St.x1) + (St.x2 * St.x2) + (St.x3 * St.x3);

cout << "суммa: " << St.amount << "\nпроизведение: " << St.composition << "\nсумму квадратов: "<<St.sum_of_squares << endl;

cout << "\n2)\n";

for (;;) {

 cout << "введите четырехразрядное число: ";

 cin >> St.number;

 if (St.number >= 1000 && St.number <= 9999) {

  St.thousand = St.number / 1000;

  St.hundreds = St.number / 100;

  St.dozens = St.number / 10;

  St.units = St.number / 1;

  cout << "Тысяч - " << St.thousand << ", сотен - " << St.hundreds << ", десятков - " << St.dozens << ", единиц - " << St.units;

  break;

 }

}

cout << "\n\n3)\n";

for (;;) {

 cout << "Введите два натуральных числа <=10\n";

 cin >> St.a >> St.b;

 if (St.a >= 0 && St.a <= 10 && St.b >= 0 && St.b <= 10) {

  St.amount_ab = St.a + St.b;

  St.difference_ab = St.a - St.b;

  St.composition_ab = St.a * St.b;

  cout << "суммa: " << St.amount_ab << "\nразность: " << St.difference_ab <<"\nпроизведение: " << St.composition_ab << endl;

  break;

 }

}

system("pause > nul");

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Впаскаль abc написать программу, которая с процедуры меняет значения переменных a, b, c так, чтобы они были расположены в порядке возрастания
Ваше имя (никнейм)*
Email*
Комментарий*