tarigor
?>

Впаскаль abc написать программу, которая с процедуры из трёх целых двузначных чисел находит то, у которого сумма цифр больше всего

Информатика

Ответы

Belokonev286
Var n,one,dec,hun,s: integer; begin writeln (' введи четырехзначное число'); readln (n); one: = n mod 10;                     ( находим цифру на месте единиц) dec: = ( n div 10) mod 10;               на   предпоследнем разряде hun: = ( n div 100) mod 10;           на третьем разряде с конца t: = n div 1000;                                 на первом разряде s: =one+dec+hun+t; if (s mod 2=0) or ( s mod 3=0 ) then writeln (' кратна 2 или 3)   else writeln (' не кратна'); end.
molodoychek
//предположим, что массив уже дан var   name_of_array : array [1.. 10] of integer : = (1,1,7,1,7,1,5,7,4,10); //дальше программа. ей всё равно, какой массив дан, главное, чтобы первый индекс был равен 1 begin var i : integer : = 1;     foreach ai : integer in name_of_array do   begin       if ai = 7 then           begin           writeln(i);           break;           end       else       i += 1;   end; end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Впаскаль abc написать программу, которая с процедуры из трёх целых двузначных чисел находит то, у которого сумма цифр больше всего
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ayk111560
kuchin
Novikova
nikolotovas
Sergei
sjmurko
ananyananar
predatorfishing608
set907
borisovaks496
salahovta
Poroskun
Nataliefremova2015808
bellatrixstudio
mouse-0211fsb3509