barnkim
?>

Паскаль (с использованием операторов if и elsе) напишите программу, которая по введенным с клавиатуры числам e, f, g, h и w будет вычислять значение коэффициента a, b и c квадратного уравнения по предлагаемым формулам, а также значение дискриминанта d, решать это квадратное уравнение и выдавать результаты его решения. a=7e-f/2, b=√((g+e)^2+h/w), c=|w^2-h| sin⁡a, где дискриминант d=b^2-4ac; корни уравнения x_1, 2=(-b±√d)/2a. отладьте программу на следующем примере: е=2, f= -5, g=-5, h=3, w=2 a=16.5 b=3.24037 c=-0.711785 d=57.4778 x1=0.131547 x2=-0.327933

Информатика

Ответы

Chistov9721209
Var
   e,f,g,h,w,a,b,c,D:real;
begin
readln(e);
readln(f);
readln(g);
readln(h);
readln(w);
a:=7*e-f/2;
b:=sqrt(sqr(g+e)+h/w);
c:=abs(sqr(w)-h)*sin(a);
D:=sqr(b)-4*a*c;
writeln('a = ',a);
writeln('b = ',b);
writeln('c = ',c);
writeln('D = ',D);
if(D<0) then writeln('Корней нет')
else if(D = 0) then
  writeln('x = ',-b/(2*a))
else
begin
  writeln('x1 = ',(-b+sqrt(D))/(2*a));
  writeln('x2 = ',(-b-sqrt(D))/(2*a));
end;
end.
Vasilevna_Shabanova1502
Const 
    x = 28.35;
var
    g : Real;
begin
    Write('Введите кол-во граммов: ');
    ReadLn(g);

    Writeln(g:0:3, ' грамм = ', g/x:0:3, ' унций.');
    Readln;
end.

2:

var 
    a, b, c : Integer; 
    m : Real;
begin
    Write('Введите сторону a: ');
    ReadLn(a);

    Write('Введите сторону b: ');
    ReadLn(b);

    Write('Введите сторону c: ');
    ReadLn(c);

    m := sqrt(2*sqr(b) + 2*sqr(c) - sqr(a))/2;
    Writeln('Медиана к стороне a = ', m:0:3);

    m := sqrt(2*sqr(a) + 2*sqr(c) - sqr(b))/2;
    Writeln('Медиана к стороне b = ', m:0:3);

    m := sqrt(2*sqr(a) + 2*sqr(b) - sqr(c))/2;
    Writeln('Медиана к стороне с = ', m:0:3);
    Readln;
end.

m = \frac{1}{2} \sqrt{2 b^{2} + 2 c^{2} - a^{2}}
Bella
Переведем длину диагонали в мм. 1"=25.4 мм, тогда длина диагонали d составит 25.4×17 = 431.8 мм.
Теперь нужно решить вопрос о соотношении сторон экрана, т.е. отношения ширины экрана к высоте. На старых мониторах использовалось соотношение 4:3, на современных - 16:9 и 16:10. Тут не угадаешь. Примем соотношение 16:9. Пусть высота экрана монитора равна h, тогда его ширина b=(16/9)*h.
По теореме Пифагора d² = b²+h². Для выбранного нами случая d² = (16/9)²*h²+h² = h²((16/9)²+1). Решаем полученное уравнение.
\displaystyle d^2=h^2\left( \frac{16^2}{9^2}+1\right); \quad d^2=h^2\left( \frac{16^2+9^2}{9^2}\right); \quad d\approx 2.038\ h; \\ h= \frac{d}{2.038}= \frac{431.8}{2.038} \approx 211.7
Если точка имеет размер 0.28мм, то по высоте экрана 211.7 мм таких точек поместится 211.7/0.28 ≈ 756. А по ширине - 756×16/9 ≈ 1344.
Получаем разрешение 1344×756. Увы, оно нестандартное, т.е. таких мониторов не выпускают. Смотрим промышленный ряд разрешений и выбираем ближайшее 1366x768. Оно немного больше полученного нами, но это скорее всего вызвано тем, что на самом деле размер точки не 0.28, а 0.2755 мм.

ответ: расчетное 1344×756, стандартное 1366×768

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Паскаль (с использованием операторов if и elsе) напишите программу, которая по введенным с клавиатуры числам e, f, g, h и w будет вычислять значение коэффициента a, b и c квадратного уравнения по предлагаемым формулам, а также значение дискриминанта d, решать это квадратное уравнение и выдавать результаты его решения. a=7e-f/2, b=√((g+e)^2+h/w), c=|w^2-h| sin⁡a, где дискриминант d=b^2-4ac; корни уравнения x_1, 2=(-b±√d)/2a. отладьте программу на следующем примере: е=2, f= -5, g=-5, h=3, w=2 a=16.5 b=3.24037 c=-0.711785 d=57.4778 x1=0.131547 x2=-0.327933
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

baton197310
alexeytikhonov
Vrpeshka
Анна1417
Михаил736
Pautova1119
Lidburg
lider123
atlantika7
annakuzina2023
Gainalii1912
Сергеевна_Юрикович
zhannasokortova
v89167233402
ielienakozlova696