mashuska
?>

Напишите программу которая вычисляет сумму всех делителей заданного натурального числа n и находит все нечетные делители этой суммы

Информатика

Ответы

kulikovtsud
Ух. тоже олимпиада по информатике ?))
An-solomon

Программа:

Pascal:

№1)

var sum, j, k: integer;

begin

 readln(j);

 while j <> 0 do begin

   inc(k);  // k - кол-во введённых чисел

   sum := sum + j;  // сумма введённых чисел

   readln(j);

 end;

 writeln(sum/k);

end.

№2)

var sum, j, k: integer;

begin

 readln(j);

 repeat

   inc(k);  // k - кол-во введённых чисел

   sum := sum + j;  // сумма введённых чисел

   readln(j);

 until j = 0;

 writeln(sum/k);

end.

№3)

3.1) var sum, j: integer;

begin

 readln(j);

 repeat

   if j mod 2 = 0 then sum += j;

   readln(j);

 until j = 0;

 writeln(sum);

end.

3.2) var sum, j: integer;

begin

 readln(j);

 while j <> 0 do begin

   if j mod 2 = 0 then sum += j;

   readln(j);

 end;

 writeln(sum);

end.

gennadevna

Программа:

Python:

import sys

max, min = -(sys.maxsize), sys.maxsize

c = 0

N = int(input('N = '))

print('Введите массив:')

arr = [int(input()) for i in range(N)]

for i in arr:

   if len(str(i)) == 2 and i % 3 == 0:

       if i < min:  min = i

       elif i > max:  max = i

if max != -(sys.maxsize):  print('Максимальное число:', max)

else: print('Нет максимального числа')

if min != (sys.maxsize):  print('Минимальное число:', min)

else: print('Нет минимального числа')

Pascal:

var

 arr: array of integer;

 N, i, max, min, j, c: integer;

procedure Symv(j: integer; var c: integer);

begin

 while j > 0 do begin

   j := j div 10;

   c += 1;

 end;

end;

begin

 max := -MAXINT;

 min := MAXINT;

 write('N = ');  readln(N);

 SetLength(arr, N);

 writeln('Введите элементы массива:');

 for i := 0 to N - 1 do readln(arr[i]);

 writeln(arr);

 

 for i := 0 to N - 1 do begin

   Symv(arr[i], c);

   if (c = 2) and (arr[i] mod 3 = 0) then begin

     if arr[i] < min then min := arr[i]

     else if arr[i] > max then max := arr[i]

   end;

   c := 0;

 end;

 

 if max <> -MAXINT then writeln('Максимальное число: ', max)

 else writeln('Нет максимального числа.');

 if min <> MAXINT then writeln('Минимальное число: ', min)

 else writeln('Нет минимального числа.');

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу которая вычисляет сумму всех делителей заданного натурального числа n и находит все нечетные делители этой суммы
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

natanikulina1735
yrgenson2011801
oyudina
Zhanibekrva Kandaurova
alekbur
brovkinay
premiumoft
mvolkov8
Dragun1684
losevev5619
Richbro7
Хохлов
dpodstrel85
bei07
evamining
▲