Lopatkin_Shchepak174
?>

Составьте программу для построения изображения треугольника.проверьте правильность выполнения на странице (зайдите гостем) . 70 ​

Информатика

Ответы

alplakhota67
Var {вводим точки, записываем в переменную max расстояние до первой точки, а в переменную max2 - номер точки. если расстояние до следующей точки меньше, чем до первой точки, то сохраняем новые значения в max и  max2} x1,y1,x2,y2,x3,y3,max,max2: real;       begin           readln(x1,y1,x2,y2,x3,y3);                     max: =sqrt(sqr(x1)+sqr(y1));                     max2: =1;                       if sqrt(sqr(x2)+sqr(y2))< =max then                          begin                                max: =sqrt(sqr(x2)+sqr(y2));                               max2: =2;                           end;                       if sqrt(sqr(x3)+sqr(y3))< =max then                          begin                              max: =sqrt(sqr(x3)+sqr(y3));                               max2: =3;                           end;       writeln(max,' ',max2);       end.
NataliaBerezovskaya33
Const   nm = 50; {максимальная длина массива} var   i, n: integer;   a: array[1..nm] of integer; begin   write('введите количество элементов в массиве: ');   readln(n);   write('введите элементы массива через пробел ');   for i : = 1 to n do   begin       read(a[i]);   end;   i : = n;   while (a[i] < = 0) and (i > 0) do dec(i);   if i > 0 then writeln('последний положительный элемент a[', i, ']=', a[i]) end. тестовое решение: введите количество элементов в массиве: 5 введите элементы массива через пробел 3 -3 5 -5 -4 последний положительный элемент a[3]=5

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу для построения изображения треугольника.проверьте правильность выполнения на странице (зайдите гостем) . 70 ​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

remontsalarievo2
Georgievna1407
mkrtchyananaida6995
sahar81305
tanyamurashova11352
platan3698952
VolkovaMaslova
Анна1169
taanaami75
Zezyulinskii Fedor
BelozerovaGeller648
Чечин-Павлова615
Компютермен жжұмыс істеңіз​
platonm777639
Lenuschakova1982316
borisova-Sergeevna
▲