inaine73
?>

Определить 3-ю цифру в записи 6-значного натурального числа. для нахождения 3 цифры надо "отрезать" от числа последние 3 и первые 2 цифры составить программу , применяя операции div и mod. .

Информатика

Ответы

Koranna1986
Var
a,a1,a2: integer;
begin
writeln ('vvedi cislo');
read (a);
a1:=a div 1000;
a2:=a1 mod 10;
writeln (a2);
end.
utburt
// ConsoleApplication60.cpp: определяет точку входа для консольного приложения.//
#include "stdafx.h"#include<conio.h>#include"iostream"#include "stdio.h"#include "time.h"
using namespace std;
int main(){ int x, y,c; setlocale(LC_ALL, "RUS"); srand((unsigned)time(NULL)); x = rand() % 8 + 2; y = rand() % 8 + 2; cout << "Сколько будет  " << x << "*" << y << "?" << "\n"; cout << "Введите ответ и нажмите Enter  "; cin >> c; if (x*y == c) { cout << "Правильно\n";  } else { cout << "Вы ошиблись   " << x << "*" << y << "=" << c;  } return 0;}
goryavinan
Uses graphabc;
 const
  W = 600;
  H = 600;

 function F(x: real): real;
begin
  F := sqr(x);
end;

 var
  x0, y0, x, y, xLeft, yLeft, xRight, yRight: integer;
  a, b, fmin, fmax, x1, y1, mx, my: real;
 begin

  window.Init(0, 0, 800, 500, clwhite);
  window.IsFixedSize := true;
  xRight := 590;
  yRight := 590;
  a := -15;
  b := 6;
  fmin := -10;
  fmax := 20;
  mx := (xRight - xLeft) / (b - a);
  my := (yRight - yLeft) / (fmax - fmin);
   x0 := 380;
  y0 := 490;
  x1 := a;
   while x1 <= b do
  begin
     y1 := F(x1);
     x := x0 + round(x1 * mx);
     y := y0 - round(y1 * my);
     if (y >= 10) and (y <= 590) then SetPixel(x, y, clblack);
     x1 := x1 + 0.001 ;
  end;
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Определить 3-ю цифру в записи 6-значного натурального числа. для нахождения 3 цифры надо "отрезать" от числа последние 3 и первые 2 цифры составить программу , применяя операции div и mod. .
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Oslopova
Кулагина_Владимир1179
si0000
gernovoy
annanas08
VolkovaMaslova
Popova-Erikhovich
Shipoopi8
pavlovm8316
Liliya-buc
vitaliy
pizniak
gubernatorov00
sergeevna
juliavovo