C1D24000 - 16-ричная форма внутреннего представления числа -26,28125 в формате с плавающей точкой в 4-х байтовой ячейке.
Объяснение:
Сначала переводим число -26,28125 без знака в двоичное представление:
целая часть:
26 : 2 = 13 ост 0
13 : 2 = 6 ост 1
6 : 2 = 3 ост 0
3 : 2 = 1 ост 1
1 : 2 = 0 ост 1
итого целая часть 26 (10) = 11010 (2)
дробная часть:
умножаем дробную часть числа (и дробные части полученных произведений) на 2 до тех пор, пока результат не станет =1 или будет достигнута требуемая точность. Целые части результатов записываем по-порядку после запятой:
0,28125 * 2 = 0,5625 --> 0,0
0,5625 * 2 = 1,125 --> 0,01
0,125 * 2 = 0,25 --> 0,010
0,25 * 2 = 0,5 --> 0,0100
0,5 * 2 = 1 --> 0,01001
Получается дробная часть 0,28125 (10) = 0,01001 (2)
Собираем все число вместе: 26,28125 (10) = 11010,01001 (2)
Теперь надо представить его в формате с плавающей точкой.
В этом формате 4 байта = 32 бита.
Распределяются биты так:
1 бит отводится под знак числа 0 или 1.
8 бит - степень
23 бит - мантисса
В нашем случае число отрицательное, значит в первый бит запишем 1.
Теперь надо определить степень и мантиссу
Степень равна показателю степени старшего разряда целой части +127
В целой части 5 цифр, значит при нумерации с нуля старший разряд будет 4 степени: 11010 = 1,1010 * 2^4
Степень = 4+127=131 (десятичное число)
переведем его в двоичное: 131 (10) = 10000011 (2)
Степень = 10000011
Определим мантиссу:
для этого представим его как произведение на 2 (основание СС) в какой-то степени:
перенесем запятую так, чтобы перед ней оказалась только одна единица (старший разряд). Показатель степени двойки при этом будет равен номеру старшего разряда (нумерация с нуля):
11010,01001 = 1,101001001 * 2^4
осталось дополнить число до 23 знаков после запятой:
1,10100100100000000000000
Мантисса = 10100100100000000000000
Собираем все вместе:
знак степень мантисса
1 10000011 10100100100000000000000
Итого число -26,28125 в машинном представлении в 4-байтовой ячейке в формате с плавающей запятой = 11000001110100100100000000000000
Осталось перевести его в 16-ричное представление:
разбиваем число на блоки по 4 цифры начиная с конца и подставляем вместо каждого блока соответствующее ему 16-ричное значение:
1100 0001 1101 0010 0100 0000 0000 0000
C 1 D 2 4 0 0 0
11000001110100100100000000000000 (2) = C1D24000 (16)
38 путей.
Объяснение:
Для задач такого вида используются довольно универсальные решения. Для города Х вводится характеристика Nх - количество различных путей из города А в город Х. На картинке, например, Nа = 1 (так как единственный попасть в город А из города А - это оставаться в нем), Nб = 1 (единственный попасть из города А в город Б - по прямому пути), аналогично для города Д.
Давайте найдем количество попасть в каждый город из города А. Для этого начнем идти из города А во все "соседние" города, для которых мы уже можем назвать это количество по принципу, описанному абзацем выше:
Nа = 1
Nб = Nа = 1
Nг = Nб + Nа = 1 + 1 = 2
Nд = Nа = 1
Nв = Nб + Nг = 1 + 2 = 3
Nе = Nг + Nд = 2 + 1 = 3
Nж = Nв + Nг + Nе = 3 + 2 + 3 = 8
Nк = Nв + Nж = 3 + 8 = 11
Nл = Nк + Nж = 11 + 8 = 19
Мы узнали количество различных путей из города А в город Л. Теперь по аналогии будем искать количество путей из города Л в город П. Чтобы не путаться, введем новую характеристику, например, Cx - количество различных путей из города Л в город X.
Cл = 1
Cм = Cл = 1
Cп = Cл + Cм = 1 + 1 = 2
19 путей из города А в город Л, и 2 путя из города Л в город П. 19 путей, если после города Л мы сразу пойдем в город П, плюс еще 19 путей, если мы после города Л зайдем сначала в город М, а уже потом в П. Итого 19 * 2 = 38 путей.
Поделитесь своими знаниями, ответьте на вопрос:
25 ! (составьте программу паскаль) уличный продавец газет получает а рублей с продажи каждой из первых 50 газет. с продажи каждой из остальных газет он получает на 20% больше. вычислите дневной заработок продавца, k газет в день.
k: integer;
a, s: real;
begin
write('Начальная стоимость: ');
readln(a);
write('Число проданных газет: ');
readln(k);
if k <= 50 then s := k * a
else
begin
s := 50 * a;
s := s + (k - 50) * a * 1.2;
end;
writeln('Выручка составила ', s, ' руб.');
end.