Irinagarmonshikova
?>

Написать программу си++ вот условие : задан массив целых чисел. отсортировать четные элементы массива по возрастанию, а нечетные по убыванию. нужно

Информатика

Ответы

Ilin1022
//Dev-C++ 5.11

#include <iostream>
using namespace std;

int main(void)
 {const int n=6;
 int arr[n],c;
 for(int i=0;i<n;i++)
  cin>>arr[i];
 for(int i=0;i<n-1;i++)
  for(int j=i+1;j<n;j++)
   if(arr[i]>arr[j] && arr[i]%2==0 && arr[j]%2==0)
    {c=arr[i];
    arr[i]=arr[j];
    arr[j]=c;}
 for(int i=0;i<n-1;i++)
  for(int j=i+1;j<n;j++)
   if(arr[i]<arr[j] && arr[i]%2!=0 && arr[j]%2!=0)
    {c=arr[i];
    arr[i]=arr[j];
    arr[j]=c;}
 cout<<"Array"<<endl;
 for(int i=0;i<n;i++)
  cout<<arr[i]<<" ";
 return 0;}

Пример ввода:
2 6 4 1 5 3
Пример вывода:
Array
2 4 6 5 3 1
varvara82193
Если текст будет в строчку,как обычно оно тут бывает,скачай мой тхт,там код в нормальном виде

var  a, b, c: integer;  a1, b1, c1: integer;
beginwhile true dobegin  writeln('Введите 3 числа');  readln(a, b, c);  if (a mod 2) = 0 then // четным плюс 1    a1 := 1;  if (b mod 2) = 0 then    b1 := 1;  if(c mod 2) = 0 then    c1 := 1;  if((a mod 2) <> 0) and ((b mod 2) <> 0) and ((c mod 2) <> 0) then //При четных нету    writeln('четных нет');  if(a1=1)and(b1=0)and(c1=0)then //если только 1 четное  writeln(a)  else   if(a1=0)and(b1=1)and(c1=0)then  writeln(b)  else   if(a1=0)and(b1=0)and(c1=1)then  writeln(c);    if (a1 = 1) or (b1 = 1) or (c1 = 1) then //Выяснение большего числа  begin    if(a1 = 1) and (b1 = 1) and (c1 = 1) then // если 3 числа четные    begin      if (a >= b) and (a >= c) then        writeln(a)      else if (b >= a) and (b >= c) then        writeln(b)      else if(c >= b) and (c >= a) then        writeln(c)    end    else if (a1 = 1) and (b1 = 1) then//если а и б четные    begin      if(a > b) then        writeln(a)      else if (b > a) then        writeln(b)    end    else if(a1=1)and(c1=1)then//если а и с    begin        if(a > c) then        writeln(a)      else if (c > a) then        writeln(c)    end    else if(b1=1)and(c1=1) then//если б и с    begin    if(b>c)then    writeln(b)    else if(c>b)then    writeln(c)    end;  end; end;end.
Kushchenko-Monashev
1.a) Из объектов
2.b) Растровое изображение
3. c) Увеличить растровое изображение
4. c) Теряются мелкие детали
5.b) Векторный
6. a) Точка
7. c) От яркости цветов на изображении
8.a) Количество цветов в палитре
9.b) Microsoft Paintc) Adobe Photoshop
10.b) Изменение размера происходит без потери качества
11.b) Растровое изображение
12.c) RGB модель
13.a) принтерe) дисплейf) графопостроитель (плоттер)
14.b) Corel Draw
15.b) растровой графики.
16.c) зеленый
17.a) JPEG  c) GIF  d) TIF  e) PNG  f) BMP  h) PCD
18.b) 256
19.a) HSB
20.b) частота дискретизации

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу си++ вот условие : задан массив целых чисел. отсортировать четные элементы массива по возрастанию, а нечетные по убыванию. нужно
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Ka2ffka141
Сергей_Крутикова114
Mbkozlov6
kurlasku
КириллЕгорова1906
danielianruz
Zhilinoe134
Devaunka40
s777tver109
Vip2002www86
myrisik2490
gullieta
Владимир1524
dashanna04225
pavelvsk2023