krutikovas
?>

Написать программу си++ и если сможете нарисуйте блок схему : задан массив целых чисел. вычислить сумму отрицательных элементов этого массива и определить их количество

Информатика

Ответы

Dato24043846
Написать программу си++ и если сможете нарисуйте блок схему : задан массив целых чисел. вычислить су
stmr29
Если будут где-то ошибки извините ,возможно в знаках)) проверьте в паскале ,если что напишите 

program prazdnik;
var a : integer ;
begin
readln(a);
if a=1  then writeln ('пишите сюда праздиники в первый месяц,какие нужны');
if a=2 then writeln ('сюда то чт ово второй ');
if a=3 then writeln (' третий ') ;
if a=4 then writeln (' четвертый месяц с его праздниками');
if a=5 then writeln (' пятый месяц');
  if a=6 then writeln (' шестой месяц'); 
 if a=7 then writeln (' седьмой месяц'); 
 if a=8 then writeln (' восьмой'); 
 if a=9 then writeln (' праздники '); 
 if a=10 then writeln ('празники '); 
  if a=11 then writeln (' праздники 11 месяца');
 if a=12 then  writeln ('двенадцатый');  
end.
frdf57
Алгоритм сортировки строки массива по возрастанию методом прямого выбора может быть представлен так:
1. Просматривая строку массива от первого элемента, найти минимальный элемент и поместить его на место первого элемента, а первый — на место минимального.
2. Просматривая строку массива от второго элемента, найти минимальный элемент и поместить его на место второго элемента, а второй — на место минимального.
3. И так далее до предпоследнего элемента.

Решение:

//Pascal
const
  n = 7;

var
  a: array[1..n, 1..n] of integer;
  i, j, min, ind: integer;

//Заполнение массива сл. числами и вывод на экран
begin
  for i := 1 to n do
  begin
    for j := 1 to n do
    begin
      a[i, j] := random(100);
      write(a[i, j]:4);
    end;
    writeln;
  end;
 
  //Сортировка строки матрицы прямым выбором
 
  for i := 1 to n - 1 do
  begin
    min := a[4, i];
    ind := i;
    for j := i + 1 to n do
      if a[4, j] < min then
      begin
        min := a[4, j];
        ind := j;
      end;
    a[4, ind] := a[4, i];
    a[4, i] := min;
  end;
  writeln;
 
    //вывод отсортированной строки
  for j := 1 to n do
  begin
    write(a[4, j]:4);
  end;
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу си++ и если сможете нарисуйте блок схему : задан массив целых чисел. вычислить сумму отрицательных элементов этого массива и определить их количество
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Shevtsov1818
m79857860146895
flerbuket332
andrew409
Алена-Петрова285
Gaziev1636
Aleksandrovna1153
игнатова_Сергей1228
Ни Дмитрий1095
Salko17
inulikb
helenavalenti2846
Ивлев1508
dmitrovlug8248
Mikhail_Magomed635
▲