Ladiga_Evgenii886
?>

Вводятся целые числа до тех пор пока не будет введен 0. определить сколько среди них четных и нечетных чисел. напишите программу используя цикл-пока(с предусловием): while do

Информатика

Ответы

minasov19
#include < iostream> using namespace std; int main() {   int n;   cin > > n;   int max = int32_min;   int max_index = 0;   for(int i = 0; i < n; i++) {     cin > > a[i];     if(a[i] > max) {       max = a[i];       max_index = i;     }   }   for(int i = 0; i < max_index; i++)      a[i]+=a[0];   cout < < max < < endl; } язык c++
studiojanara
1)#include < stdio.h>   int main() {  int a = -1;   while(a ! = 0)    scanf("%d", & a); }2)#include < stdio.h> #include < math.h>   int main() {  int a;   scanf("%d", & a);   int prime = 1;   for(int i = 2; i < = sqrt(a)+1; i++)    if(a%i == 0) {      prime = 0;       break;     }  if((prime == 0 & & a ! = 2) || a == 1) printf("no\n");   else printf("yes\n"); }3)#include < stdio.h> int main() {  int a[5];   for(int i = 0; i < 5; i++)    scanf("%d", & a[i]);   for(int i = 0; i < 5; i++)    printf("%d ", a[i]);   printf("\n"); }

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Вводятся целые числа до тех пор пока не будет введен 0. определить сколько среди них четных и нечетных чисел. напишите программу используя цикл-пока(с предусловием): while do
Ваше имя (никнейм)*
Email*
Комментарий*