Руслан1360
?>

Напишите программу: мальчик саша учится в школе ш, одна из особенностей которой состоит в том что на уроках в ней ставят только двойки и пятёрки. саша заранее узнал, на каких уроках языка он получит 2, а на каких — 5. саша идёт на деревянную медаль, и поэтому ему надо получить оценку за год не ниже 4 (четвёрка ставится, если хотя бы половина оценок — пятёрки, и при этом есть хотя бы одна оценка он хочет прогулять часть уроков, чтобы исправить ситуацию (если саша прогуливает урок, он не получает никакой оценки). но саша — добропорядочный мальчик, поэтому он хочет прогулять минимальное количество уроков. ему.

Информатика

Ответы

tgeraskina
//Dev-C++ 5.11 (C)

#include <stdio.h>
#include <stdlib.h>
#include <malloc.h>

int main(void)
 {int n,mark,count2=0,count5=0,res;
 printf("Enter number of classes:");
 scanf("%d",&n);
 printf("Enter marks:\n");
 for(int i=0;i<n;i++)
 {scanf("%d",&mark);
 if(mark==5) count5++;
    if(mark==2)
     count2++;}
    res=count2-count5;
    if (res<0)
  res=0;
    if (count5==0)
  printf("Impossible");
 else
  printf("%d",res);
 return 0;}

Пример ввода:
3
5
2
2
Пример вывода:
1
Ivanova55878
//искать угол будем по теореме косинусов
Program n1;
var x,y,z:real;
function arccos(x : real) : real; {это понадобится для теор. кос.}
begin
arccos := 2 * arctan(sqrt((1 - x) / (1 + x)));
end;
procedure ygl( a,b,c: real); {процедура для удобства}
var ga: real;
begin
ga:=arccos((sqr(a) + sqr(b) - sqr(c))/(2 * a* b)) * 180 / pi; {сама теор. кос.}
writeln('угол С= ',ga:5:2);
end;
begin
write('введите сторону а: ');
readln(x);
write('введите сторону b: ');
readln(y);
write('введите сторону c: ');
readln(z);
if(x>=y+z)or(y>=x+z)or(z>=x+y)then writeln('Это не треугольник')
else if x*x+y*y=z*z then {теорема пифагора}
writeln('Это прямоугольный треугольник')
else if (x*x+y*y>z*z)and(x*x+z*z>y*y)and(z*z+y*y>x*x)
then
begin
writeln('Это остроугольный треугольник');
ygl(x,y,z); {вызываем процедуру}
end
else
begin
writeln('Это тупоугольный треугольник');
ygl(x,y,z);
end;
end.
makashi28
Пишите процедуру - функцию нахождения минимума для двух чисел, например, minn(a,b: real) : real;   Считываете три числа  a,b,c,  находите минимум из чисел a и b  minn(a,b), присваиваете найденное значение переменной d,  затем находите минимум среди чисел d и с   minn(d,c) - присваиваете найденное значение переменной d - это и будет результат

На паскале:

var a,b,c,d: real;

function minn(a,b: real): real;
begin
  if a>b then minn:=b
  else minn:=a;
end;

begin
  write('числа a b c через пробел: ');  
  readln(a,b,c);
  d:=min(a,b);
  d:=min(d,c);
  writeln('минимум:  ',d);
end.

Ввод - вывод:

числа a b c через пробел: 21 6 2 
минимум:  2

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу: мальчик саша учится в школе ш, одна из особенностей которой состоит в том что на уроках в ней ставят только двойки и пятёрки. саша заранее узнал, на каких уроках языка он получит 2, а на каких — 5. саша идёт на деревянную медаль, и поэтому ему надо получить оценку за год не ниже 4 (четвёрка ставится, если хотя бы половина оценок — пятёрки, и при этом есть хотя бы одна оценка он хочет прогулять часть уроков, чтобы исправить ситуацию (если саша прогуливает урок, он не получает никакой оценки). но саша — добропорядочный мальчик, поэтому он хочет прогулять минимальное количество уроков. ему.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

oleonov
sashaleb88
Sergei1805
YeVgenii
warlordkolomna
Negutsa_Kseniya524
maxkuskov2485
GridnevaVNIGNI&quot;
сузанна_Людмила
Tkachenko1050
Nonstop788848
timeev3160
bessalaias
Misyura_Viktoriya1683
Ulianev77
▲