Андрей Анна22
?>

При датчика случайных чисел ввести три целых случайных числа a, b и c в диапазоне от 3 до 10. написать программу, отвечающую на вопрос: "можно ли построить треугольник со сторонами, равными этим числам? ". если можно построить, то найти еще стороны и углы треугольника. написать программу с функции в visual basic

Информатика

Ответы

eisakov86

Задания 10.

А) Топология с общей шиной

Б) Топология звезда

В) Кольцевая топология

Г) Полносвязная топология

Д) Полносвязная топология

Задания 11.

У данной топологии очень много плюсов:

высокая скорость и большой объём обмена данными;

повреждение передающего кабеля или поломка одного элемента (кроме центрального) не снижает работо сети;

широкие возможности для расширения, достаточно смонтировать новый кабель или настроить доступ на коммутаторе;

простая диагностика и ремонт;

легкий монтаж и сопровождение.

Поэтому она самая ра .

Объяснение:

Алина Ракитин1730

// Первая программа

program One;

var a, b: Integer;

begin

write('Введите числитель: ');

read(a); {ввод числителя}

write('Введите знаменатель: ');

read(b); {ввод знаменателя}

{Правильной называется дробь, у которой модуль числителя меньше модуля знаменателя,

поэтому проверяем это условие}

if abs(a)<abs(b) then

 {Если условие выполняется, то пишем, что дробь правильная}

 writeln('Дробь правильная.')

else

 {В противном случае пишем, что дробь неправильная}

 writeln('Дробь неправильная.')

end.

// Вторая программа

program Two;

var a, b: Integer;

begin

write('Введите первое число: ');

read(a); {ввод первого числа}

write('Введите второе число: ');

read(b); {ввод второго числа}

{Проверить число на делимость можно с операции взятия остатка.

Есть остаток — число нацело не делится; остаток равен 0 -- число делится нацело}

if (a mod b) = 0 then

 {Если остатка нет, то пишем, что первое число делится нацело на второе}

 writeln('Первое число делится на второе.')

else

 {В противном случае пишем, что первое число не делится нацело на второе}

 writeln('Первое число не делится на второе.')

end.

// Третья программа

program Three;

var a, b: Integer;

begin

write('Введите первое число: ');

read(a); {ввод первого числа}

write('Введите второе число: ');

read(b); {ввод второго числа}

{Если второе число меньше первого -- то будем выводить его,

так как в ином случае первое и второе числа равны (и тогда мы можем вывести

любое из них, они ж одинаковые), либо меньшее число -- первое, и мы выведем его}

write('Наименьшее число: ');

if (a > b) then

 {Если второе число меньше первого, его и выводим}

 writeln(b)

else

 {В противном случае выводим первое число}

 writeln(a)

end.  

Объяснение:

Пояснения находятся в фигурных скобках.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

При датчика случайных чисел ввести три целых случайных числа a, b и c в диапазоне от 3 до 10. написать программу, отвечающую на вопрос: "можно ли построить треугольник со сторонами, равными этим числам? ". если можно построить, то найти еще стороны и углы треугольника. написать программу с функции в visual basic
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

mikchaylovaalex
iraimironova
Irina321t
Likhomanova63
Rustamov741
sbraginets
Vladstreletskiy
juliaydodova
scraer198258
buyamel
marimelons795
larisau41
avguchenkov
annakorolkova79
myataplatinumb348