lovel24
?>

Напишите программу требуется определить, бьет ли ладья, стоящая на клетке с указанными координатами (номер строки и номер столбца), фигуру, стоящую на другой указанной клетке. входные данные вводятся четыре числа: координаты ладьи (два числа) и координаты другой фигуры (два числа), каждое число вводится в отдельной строке. координаты - целые числа в интервале от 1 до 8. выходные данные требуется вывести слово yes, если ладья сможет побить фигуру за 1 ход и no - в противном случае.

Информатика

Ответы

rigina82
//Dev-C++ 5.11 (C)

#include <stdio.h>
int main(void)
 {int x,y,xl,yl;
 scanf("%d%d%d%d",&xl,&yl,&x,&y);
 if((xl==x)||(yl=y))
  printf("YES");
 else
  printf("NO");
 return 0;}

Пример ввода:
4 4 4 2
Пример вывода:
YES
Ваган Шутова332

алгоритм — это предназначенное для конкретного исполнения точное описание последовательности и действий, направленных на решение поставленной .

свойства алгоритма.

дискретность — разделение алгоритма на последовательность шагов.

результативность — получение из исходных данных результата за конечное число шагов.

массовость — возможность применения алгоритма к большому количеству различных исходных данных.

детерминированность (определенность) — исполнитель должен выполнять команды алгоритма в строго определенной последовательности.

выполнимость и понятность — алгоритм должен содержать команды, входящие в систему команд исполнителя и записанные на понятном исполнителю языке.

mvolkov8

Объяснение:

1. var i: integer;

var z, s: double;

begin

i := 1;

z := 512;

s := 0;

while i <= 10 do

 begin

  s := s + i/z;

  inc(i);

  z := z/2;

 end;

writeln(s:0:2);

end.

2. var i, k: integer;

begin

i := 0;

k := 0;

repeat  

 inc(i);

 if ((i mod 2) = 0) then inc(k);

until i=5;

write(k);

end.

3. var i, n: integer;

begin

i := 0;

n := 0;

while i<10 do

 begin

  n := random (31) + 10;

  if ((n mod 2) = 0) then  

    begin

      writeln(n);

      inc(i);

     end;

 end;

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу требуется определить, бьет ли ладья, стоящая на клетке с указанными координатами (номер строки и номер столбца), фигуру, стоящую на другой указанной клетке. входные данные вводятся четыре числа: координаты ладьи (два числа) и координаты другой фигуры (два числа), каждое число вводится в отдельной строке. координаты - целые числа в интервале от 1 до 8. выходные данные требуется вывести слово yes, если ладья сможет побить фигуру за 1 ход и no - в противном случае.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

almazsit85
Анна498
magsh99
komarov-dmitriy
Pavlushina-Novikova
vik-2202
drappaeva68
FATAHOVAMAINA
vovkiv7864
hrim5736
Konstantin_Vadimirovich
egoryandiana3727283
shalunovroman
mg4954531175
pavelriga5