varvara82193
?>

Написать программу на pascal из трехзначного числа x вычли его последнюю цифру. когда результат разделили на 10, а к частному слева приписали последнюю цифру числа x. то получилось число n. по заданному n найти число x (значение n вводится с клавиатуры, 10< =n< =999 , и при этом число десятков в n не равно нулю

Информатика

Ответы

Rubber-soul
Если было число ABC = X, то после деления на 10 стало AB, а после приписывания слева CAB = N. Для получения из N числа X просто переставляем первую цифру в конец.

var
  N: integer;

begin
  readln(N);
  write(10 * (N mod 100) + (N div 100))
end.
Татьяна_Полулях
Последовательности длиной 7, содержащей 5 букв А могут быть следующими:
** (* - любой из символов В или С)
*А*
ААА*АА*
АА*ААА*
А**
** (пока 6 вариантов)
Далее - аналогично:
**А
ААА*А*А
АА*АА*А
А*ААА*А
**А (ещё 5 вариантов)
ААА**АА
АА*А*АА
А*АА*АА
*ААА*АА (ещё 4 варианта)
АА**ААА
А*А*ААА
*АА*ААА (ещё 3 варианта)
А**
*А* (ещё 2)
** (ещё 1)
Итого: 6+5+4+3+2+1=21
Так как на месте * могут быть любые из 2 символов В или С, то это даст ещё по 4 варианта для каждого случая.
Можно здесь, конечно, комбинаторику вспомнить.
Итого: 21*4 = 84
Coffee3862
Каждый символ в кои-8 имеет объем информации 1 байт. всего текста 60*30 = 1800 байт на каждой странице. растровое изображение передает не более 8 = 2^3 цветов, значит, на кодировку цвета используется 3 бита. размер каждого рисунка 120*240*3 = 86400 бит = 10800 байт. а рисунков 2 на каждой странице. таким образом, каждая страница содержит 2*10800 + 1800 = 23400 байт. модем со скоростью передачи 28800 бит в сек передал документ за 5 сек. значит, он передал 28800*5 = 144000 бит = 18000 байт. но это меньше, чем находится на одной странице. вывод: у вас ошибка в условии.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на pascal из трехзначного числа x вычли его последнюю цифру. когда результат разделили на 10, а к частному слева приписали последнюю цифру числа x. то получилось число n. по заданному n найти число x (значение n вводится с клавиатуры, 10< =n< =999 , и при этом число десятков в n не равно нулю
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

schernov
e-s-i-k
Veselova
timsch12
ckati
pnat1235
osipovasalex5316
Tyukalova
kodim4
nataliagoncharenko
Aleksei Biketova
office
si0000
Oksana373
alex091177443
▲