cutur3414
?>

Нужно написать программу на с++ напишите программу, которая вычисляет выражение, состоящее из трех чисел и двух знаков (допускаются только знаки «+» или «–» выражение вводится как символьная строка, все числа целые. пример: введите выражение: 12-3+45 ответ: 54

Информатика

Ответы

ridyana504

const

  n = 30;

var

  a: array[1..n] of byte;

  i, count: integer;

begin

  randomize;

  for i : = 1 to n do

  begin

      a[i] : = random(51) + 150;

      writeln('рост претендета № ', i: 2, ' - ', a[i]);

  end;

  write('номера подходящих кандидатур: ');

  for i : = 1 to n do

      if a[i] > = 180 then

      begin

          inc(count);

          write(i, ' ');

      end;

  writeln;

  writeln('общее количество подходящих претендентов: ', count);

end.

VolkovaMaslova

1)program z1; var st: string; i,j,k: integer; begink: =ord('a'); for i: =1 to 26 do beginfor j: =1 to i do beginwrite(chr(k)); end; k: =k+1; end; end.

2)program z2; var st: string; i,c,c1: integer; beginwriteln('введите строку'); readln(st); for i: =1 to length(st) do beginif st[i]='а' then inc(c); if st[i]='о' then inc(c1); end; if c> c1 then writeln('да') else writeln('нет'); end.

3)program z3; var st,st1,st2,st3: string; k,n: integer; beginwriteln('введите строку'); readln(st); writeln('введите k'); readln(k); n: =length(st); st1: =copy(st,1,k); st2: =copy(st,n-k+1,k); st3: =copy(st,k+1,n-2*k); st: =st2+st3+st1; writeln(st); end.

4)program z4; var st,st1,st2: string; n,i: integer; beginwriteln('введите строку'); readln(st); writeln('введите букву для удвоения'); readln(st1); n: =length(st); for i: =1 to n do begin; if st[i]=st1 then st2: =st2+st[i]+st[i] else st2: =st2+st[i]; end; writeln(st2); end.

5)program z5; var st,st1: string; n,i: integer; beginwriteln('введите строку'); readln(st); n: =length(st); for i: =1 to n do beginif (st[i]='ж') or (st[i]='ш') then st1: =st1+st[i]+'и' else st1: =st1+st[i]; end; writeln(st1); end.

6)program z6; var st,st1: string; n,i: integer; beginwriteln('ââåäèòå ñòðîêó'); readln(st); n: =length(st); st: =' '+st+' '; for i: =1 to n doif st[i]=' ' then begin delete(st,i+1,1); delete(st,i-1,1); end; writeln(st); end.

(все программы проверени и откомпелированы на pascal. net, если есть вопросы, пишите.)

 

 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нужно написать программу на с++ напишите программу, которая вычисляет выражение, состоящее из трех чисел и двух знаков (допускаются только знаки «+» или «–» выражение вводится как символьная строка, все числа целые. пример: введите выражение: 12-3+45 ответ: 54
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

l250sp70
coleslow12
preida-2
skalegin68
Щербаков33
Vitalevich1187
angelinaugan119
yok887062
Дудина895
Nikolaevich1534
iracaenko153
nadjasokolova2017
diana-020
vadim1140
mrubleva42