elenabarskova7145
?>

Синформатикой напишите программу, которая заполняет массив из 20 элементов случайными числами на отрезке [100; 200] и находит в нём пару соседних элементов, сумма которых минимальна.

Информатика

Ответы

bikemaster
C++:
for(int i = 0; i< 20; i++){
a[i]=rand()%101+100;
}
int pos=0;
for(int i = 0; i< 20; i++){
if(a[i]+a[i+1]<a[pos]+a[pos+1]){
pos=i;
}
enot1975
Var a:array[1..20] of integer;
i,min,ind:integer;
begin 
randomize;
for i:=1 to 20 do begin
a[i]:=random(100)+100;
write(a[i]:4);
end;
writeln;
min:=a[1]+a[2];
for i:=2 to 19 do
if a[i]+a[i+1]<min then 
begin 
min:=a[i]+a[i+1];
ind:=i;
end;
write('Сумма минимальна между ',ind,' и ', ind+1, ' элементом');
end.
veronica1344
Поиск простых делителей числа:

var i,j,n:longint;
    f:boolean;
begin
 writeln('Введите число');
 readln(n);
  if n<2 then writeln('Простых делителей нет')
  else
   begin
    write('Число ',n,' ','= 1');
    for i:=2 to n do
     if n mod i=0 then
      begin
       f:=true;
       j:=2;
       while f and(j<=round(sqrt(i/2)))do
        begin
         if i mod j=0 then f:=false
         else j:=j+1;
        end;
      if f then write('*',i);
     end;
   end;
end.

Тестовое решение:

Введите число
2345
Число 2345 = 1*5*7*35*67
Цветкова
Алгоpитм — точное и понятное пpедписание исполнителю совеpшить последовательность действий, направленных на решение поставленной задачи.

Основные свойства алгоритмов:

Понятность для исполнителя
Дискpетность (прерывность, раздельность) — алгоpитм должен пpедставлять пpоцесс pешения задачи как последовательное выполнение пpостых (или pанее опpеделенных) шагов (этапов).
Опpеделенность — каждое пpавило алгоpитма должно быть четким, однозначным и не оставлять места для пpоизвола.
Pезультативность — это свойство состоит в том, что алгоpитм должен пpиводить к pешению задачи за конечное число шагов.
Массовость. Алгоpитм pешения задачи pазpабатывается в общем виде.
Формы представления алгоритмов.

• словесная (записи на естественном языке);
• графическая (изображения из графических символов);
• псевдокоды (полуформализованные описания алгоритмов на условном алгоритмическом языке;
• программная (тексты на языках программирования).

Словесный записи алгоритмов представляет собой описание последовательных этапов обработки данных.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Синформатикой напишите программу, которая заполняет массив из 20 элементов случайными числами на отрезке [100; 200] и находит в нём пару соседних элементов, сумма которых минимальна.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ovdei71
Семеновна-Павел
familumid
pak1998378
Екатерина_Кирушев
ikhilovb76
Карева Даниил1537
VladimirBorisovich
zanthia94
info2
modellisimo-a
POMILEVAVladimirovna269
eurostom
Aleksey19801
Astrians
▲