yanagitsina
?>

Задана следующая шкала эффективности внедрения технологий(% 0-10 – невысокая; 11-25 – средняя; 26-50 – высокая; 51 – 100 – высокая; > 100 – революционная. составить программу, которая по введенной эффективности выдает ее словесную характеристику. pascal abc

Информатика

Ответы

Anait_Natalya451
Var
  p:integer;
begin
  Write('Укажите процент эффективности: '); Read(p);
  case p of
  0..10:Writeln('Невысокая');
  11..25:Writeln('Средняя');
  26..50:Writeln('Высокая');
  51..100:Writeln('Очень высокая');
  else Writeln('Революционная')
  end
end.
Anton661

010

Объяснение:

Изобразим все возможные коды длиной не больше 4 в виде дерева (см. рис.)

Красным цветом помечены вершины, которым соответствуют уже занятые коды. Условие Фано запрещает одному коду быть префиксом (началом) другого, желтым цветом отмечены коды, выбор которых будет противоречить условию Фано (например, если занят код 0010, то нельзя выбрать коды 0, 00, 001).

Оставшиеся не закрашенными коды доступны для выбора, они удовлетворяют условию Фано, а значит, код будет допускать однозначное декодирование. По рисунку видно, что наименьшая длина кода равна 3, есть два варианта: 100 и 010. В ответ пойдёт более правый код, у него числовое значение меньше.


Для кодирования некоторой последовательности, состоящей из букв а, б, в, г, д, е, ж, з, и, й. решили
Vitproficosmetics

010

Объяснение:

Изобразим все возможные коды длиной не больше 4 в виде дерева (см. рис.)

Красным цветом помечены вершины, которым соответствуют уже занятые коды. Условие Фано запрещает одному коду быть префиксом (началом) другого, желтым цветом отмечены коды, выбор которых будет противоречить условию Фано (например, если занят код 0010, то нельзя выбрать коды 0, 00, 001).

Оставшиеся не закрашенными коды доступны для выбора, они удовлетворяют условию Фано, а значит, код будет допускать однозначное декодирование. По рисунку видно, что наименьшая длина кода равна 3, есть два варианта: 100 и 010. В ответ пойдёт более правый код, у него числовое значение меньше.


Для кодирования некоторой последовательности, состоящей из букв а, б, в, г, д, е, ж, з, и, й. решили

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Задана следующая шкала эффективности внедрения технологий(% 0-10 – невысокая; 11-25 – средняя; 26-50 – высокая; 51 – 100 – высокая; > 100 – революционная. составить программу, которая по введенной эффективности выдает ее словесную характеристику. pascal abc
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

assistant
Igorevich1559
Роман
archala
Шапкина1531
natanikulina1735
КутузоваМартенюк
mrFuz
ТигранКалмыкова
goldglobustour725
samsakovs7757
vikola2008
grigoriev8
Serkova_Elena251
ivanandrieiev1984268