Ярослав
?>

Написать программу на pascal'e: массив a содержит натуральные числа. создать массив b, который содержит только простые числа из a в порядке возрастания. массив b сортировать методом простого выбора. вывести на печать массив b или сообщить, что он пуст.

Информатика

Ответы

vovababkin1477
Предположим, что иллюминатор - это круглое отверстие диаметром d, а сундук для простоты опишем параллелепипедом с ребрами a, b, c. очевидно, что сундук пройдет в иллюминатор, если прямогольник, образованный двумя его меньшими ребрами, будет вписан в окружность иллюминатора, т.е. диагональ этого прямоугольника будет меньше диаметра иллюминатора. из трехмерной сводится к двухмерной, т.е. решается в плоскости, для чего нужно отбросить из рассмотрения ребро максимальной длины, т.е. из множества ребер {a,b,c} мы исключаем ребро, длина которого равна max(a,b,c). пусть это будет ребро с, тогда рассматриваем ребра a и b. диагональ прямоугольника можно найти по теореме пифагора и она равна √(a²+b²). но можно (и рациональнее), не извлекать квадратный корень, а сравнить квадрат диагонали с квадратом диаметра, т.е. условием извлечения сундука будет a²+b² < d² наша может может быть описана логической функцией f, которая принимает значение "истинно", если сундук может быть извлечен, и ложно в противном случае.
vadim330
Var b,c: integer; a: array [1..20] of integer; {объявляем массив} begin randomize;   {говорим что будем использовать в теле программы рандомные числа} for b: =1 to 15 do begin  {жи есть цикл программы который заполняет наш массив от первой ячейки (b) до 15 ячейки  } a[b]: =random(1000);   {присваиваем элементам массива рандомные значения} write(a[b]);   {выводим эти значения} writeln(' < == ',a[b]*2);   {рядом выводим точно такой же массив с такими же числами, только умноженными на 2 , а стрелочка для красоты  } end; end.надеюсь что так можно? ; d

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на pascal'e: массив a содержит натуральные числа. создать массив b, который содержит только простые числа из a в порядке возрастания. массив b сортировать методом простого выбора. вывести на печать массив b или сообщить, что он пуст.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

samira57
Сергей_Крутикова114
Moroshkina-Aristova2011
Segyn1218
Telenkovav
orb-barmanager
Aleksandrovich1415
miss1380
lbeglarova6
tenvalerij
horst58
Давид-Ольга
Kochinev4
Романенко
gelena03