informalla
?>

Спрограммой ! на языке паскаль . напишите программу, которая заполняет массив из 20 элементов случайными числами на отрезке [–100; 100] и находит в каждой половине массива пару соседних элементов, сумма которых максимальна .

Информатика

Ответы

alaevluka77
Var a:array[1..20] of integer;
i,max1,ind1,max2,ind2:integer;
begin 
randomize;
for i:=1 to 20 do begin
a[i]:=random(200)-100;
write(a[i]:4);
end;
writeln;
max1:=a[1]+a[2];
for i:=2 to 9 do
if a[i]+a[i+1]>max1 then 
begin 
max1:=a[i]+a[i+1];
ind1:=i;
end;

max2:=a[11]+a[12];
for i:=12 to 19 do
if a[i]+a[i+1]>max2 then 
begin 
max2:=a[i]+a[i+1];
ind2:=i;
end;

write('Сумма максимальна между ',ind1,' и ', ind1+1, ' элементом в первой половине и между ',ind2,' и ',ind2+1,' во второй половине массива');
end.
alena

По горизонтали:

4. Устройство для записи, считывания и длительного хранения информации на гибких магнитных дисках (дискетах).

7. Устройство, предназначенные для вывода на экран текстовой и графической информации.

9. Ячейки памяти, которые служат для кратковременного хранения и преобразования данных и команд.

11. Линия связи к которой подключена сеть.

13. Устройство для записи, считывания и длительного хранения информации на жестких магнитных дисках.

14. Устройство ввода звуковой информации.

15. Системная магистраль передачи данных.

По вертикали:

1. Устройство для вывода чертежей на бумагу.

2. Электронная схема, которая управляет работой какого-либо внешнего устройства.

3. Устройство для обмена информацией между компьютерами через телефонные, оптоволоконные и др. сети.

5. Вс процессор, предназначенный для выполнения математических и логических действий.

6. Небольшая электронная схема, выполняющая все вычисления и обработку информации.

8. Устройство вывода звуковой информации.

10. Устройство для считывания графической и текстовой информации в компьютер с бумажных носителей информации.

12. Печатающее устройство, предназначенные для вывода информации на бумагу.

14. Манипулятор для ввода информации в компьютер.

Надеюсь !

Olga-Lev1160

ответ:#include <iostream>

using namespace std;

void myFunc(int k) {

bool flag = true;

for(int i=2; i<k; i++)

{

 if(k%i==0)

 {

  flag = false;

 }

 

}

if(flag==true)

{

 cout<<"Yes"<<endl;

}

else

{

 cout<<"No"<<endl;

}

}

int main(int argc, char** argv) {

int a;

cout<<"Input a: ";

cin>>a;

myFunc(a);

return 0;

}

Объяснение: Создаем функцию которая ничего не возвращает, она принимает аргумент К. Это и есть число какое будем вводить. Создаем буллевую переменную. Делаем цикл с числа 2. Т.к 1, 2 простые. Смысла проверять нет. Если остатка от деления числа К на І не будет - значит оно не простое. Далее проверяем наш flag, main думаю понятно

P.S: Если не там Yes или No просто поменяй их текст

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Спрограммой ! на языке паскаль . напишите программу, которая заполняет массив из 20 элементов случайными числами на отрезке [–100; 100] и находит в каждой половине массива пару соседних элементов, сумма которых максимальна .
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

levsha-27509
misie1974
cheremetdiana
Рогов1996
miumiumeaow
sergeymartyn56
Грачева мураховская
maxchuev
anna-ditman
com4047797
mpityk
Sergei Gaishun
pavtrusov
sales5947
andrey4work918