victoria-112296363
?>

Написать программу на языке с++. дано натурально число а в десятичной системе счисления. если все цифры числа а различные, то вывести на экран сообщение "да", иначе - сообщение "нет".

Информатика

Ответы

tomogradandrey
#include <iostream>
using namespace std;

int main()
{
    int a;
    int k[9];
    bool f = true;
    cout << "a = ", cin >> a, cout << "\n";
    for (int i=0; i<10; i++) k[i]=0;
    while (a>0){
    k[a % 10]++;
    a = a / 10;
    }
    for (int i=0; i<10; i++){
    if (k[i]>1) f = false;
    }
    if (f) cout << "Да" << "\n";
    else cout << "Нет" << "\n";
    return 0;
}

Пример:
a = 12523
Нет
Александра440
Информационные ресурсы и сервисы компьютерных сетей
Средства обеспечения определенных информационных услуг для пользователей сети принято называть службами Интернета. Кроме понятия «служба» существует еще понятие «сервис». Часто разницу между ними довольно трудно уловить. Число различных служб и сервисов в сети непрерывно растет. Опишем лишь некоторые самые известные службы, разделив их на коммуникационные и информационные.

Еще раз обратим внимание на то, что все службы Интернета основаны на взаимодействии двух программ. Одна из этих программ - сервер, а другая программа - клиент. Они взаимодействуют по определённым правилам, заданным в протоколах

Протокол службы - технический стандарт (система правил), определяющий технические особенности взаимодействия почтовых серверов друг с другом и с почтовым клиентом.

Если протокол ТСР/IР называется базовым протоколом Интернета, то протоколы служб можно назвать прикладными протоколами (иногда их называют протоколами второго уровня).

Поясним смысл еще двух терминов, которые будут дальше использоваться. Режим on-line — это режим работы пользователя в состоянии подключения к какому-либо серверу Сети. Состояние отключенной связи называется режимом оff-line. Аналогия: общение по телефону всегда происходит в режиме on-line. При отправлении телеграммы вы заполняете бланк в режиме оff-line, затем телеграфист в режиме on-line передает телеграмму по линии связи; а затем получатель читает телеграмму в режиме оff-line.
i7aster26

13620 байт

Объяснение:

Считаем количество символов: "собака, " содержит 8 символов. Значит объем текста до замены: 681*8 символов.

После замены количество символов в каждом слове увеличилось на 2: вместо 2-х символов a стало 4 символа _, т.е на 4 - 2 = 2 символа больше. Всего слов 681, следовательно объем текста увеличился на 2*681.

(681*8 + 681*2)*16 = 6810*16 (бит) = 6810*2*8 = 6810*2 (байт) = 13620 байт

P.S. Можно рассуждать проще: было "собака, ", стало "соб__к__, ", т.е. 10 символов в слове. Скопировано 680 раз, т.е 10 + 680*10 = 6810.

Информационный объем равен 6810*16 бит = 13620 байт

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на языке с++. дано натурально число а в десятичной системе счисления. если все цифры числа а различные, то вывести на экран сообщение "да", иначе - сообщение "нет".
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

chaa140
zerckaln
Vitalevich
kulagin777
Лоскутова
Rizhov Alekyan325
deshkina82
Андрееевич787
Информатика тест на ЯКласс
Konstantinovna Ilyukhin1618
kristinmk
mac4roc3781
Tatgri
Ваган Шутова332
charlie79
ii090758