spec-nt
?>

Составьте программу, которая позволяет ввести элементы массива а с клавиатуры и выводит на экран количество отрицательных элементов и их индексы. p.s. не надо искать ответ в инете, т.к. там не правильно

Информатика

Ответы

ksvish2012
// PascalABC.NET 3.2, сборка 1338 от 16.11.2016
begin
  var a:=ReadArrInteger('Введите 10 чисел, нажмите Enter'+#13#10,10);
  var t:=a.Select((x,i)->(x,i+1)).Where(x->x[0]<0);
  Write('Отрицательных- ',t.Count,'; их номера ');
  t.Select(x->x[1]).Println
end.

Пример
Введите 10 чисел, нажмите Enter
 3 14 0 -13 6 -11 -4 0 7 12
Отрицательных- 3; их номера 4 6 7
Darialaza
А - количество порций эскимо на столе
В - количество стаканчиков на столе

Начало

Ввод данных:
В : = 18
А : = В/3

Действие 1:
В : = В - 3

Действие 2:
А:= А-5

Вывод результатов:
Покажи А
Покажи В

Конец

Протокол выполнения алгоритма:
№ команды  Имя переменной   Значение переменной 
1.                          В                                    18
2.                          А                                      6
3.                          В                                    15
4.                          А                                       1
 
gulyaizmailova
Информация (от лат. informatio — «разъяснение, изложение, осведомлённость») — сведения о чём-либо, независимо от формы их представления.
Информатика (от информация и автоматика) — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации, обеспечивающих возможность её использования для принятия решений.
Компьютер (англ. computer, МФА: — «вычислитель») — устройство или система выполнять заданную, чётко определённую последовательность операций.
Текстовый редактор — самостоятельная компьютерная программа или компонент программного комплекса (например, редактор исходного кода интергрированной среды разработки или окно ввода в браузере), предназначенная для создания и изменения текстовых данных вообще и текстовых файлов в частности.
Графический редактор — программа (или пакет программ), позволяющая создавать и редактировать двумерные изображения с компьютера.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, которая позволяет ввести элементы массива а с клавиатуры и выводит на экран количество отрицательных элементов и их индексы. p.s. не надо искать ответ в инете, т.к. там не правильно
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

julya847
corneewa20096
scorpion21c
al2nik2ol
yulialoveinthelow2010
natalya2321
Иван1764
aananasAnastiya1270
Svetlana1335
Wlad967857
madjk
purchase
asker45967
blackpoint2020273
Наталья