strannaya2018
?>

Составьте программу, которая осуществляет ввод в массив с клавиатуры размер 5 файлов в байтах ( от 100 до 9000 байт) и преобразует значения, превышающие 1024 байт, в килобайты.результат выводится в строку. в pascal abc

Информатика

Ответы

fta1309
Var
b:array[1..5] of real;
i:integer;
begin
for i:=1 to 5 do begin
write('Введите размер ',i,'-го файла в байтах: ');
readln(a[i]);
end;
for i:=1 to 5 do
if a[i]>1024 then a[i]:=a[i]/1024;
for i:=1 to 5 do
write(a[i]:4:1);
end.
гайсанов

Калькулятор дней между двумя датами может использоваться в самых различных ситуациях. К примеру, хотите узнать, сколько дней вы прожили? Введите дату своего рождения и сегодняшнюю дату в калькулятор и вы узнаете результат. Предположим, что вы родились 2 декабря 1984 года, а сегодня 17 ноября 2015. Если ввести эти даты в калькулятор дней, то он выдаст ответ — вы прожили 11 307 дней. Кстати, узнать в какой день недели вы родились можно здесь.

Иногда интересно узнать сколько дней с памятного события. Все мы знаем, что Великая Отечественная война завершилась 9 мая 1945 года. С калькулятора легко определить, что с момента окончания ВОВ дней (учитывая, что сегодня 17 ноября 2015 года). Если же преобразовать эту цифру в годы и месяцы, то — 70 лет 6 месяцев и 8 дней.Можно также определить сколько длилась ВОВ. Если мы введем дату начала войны 22 июня 1941 года и дату ее окончания 9 мая 1945 года, то узнаем, что Отечественная война длилась 1417 дней. При этом началась она в воскресенье, а закончилась в среду.




Напишите программу калькулятор дат,которая выводит календарь на любой год, подсчитывает количества
Vladimirovich351
Uses crt;
const max=15;
var  a : array[1..max] of integer; 
i,k0,k1,k3 : integer;  
k:boolean;
begin     
randomize;     
k0:=0;     
k1:=0;     
writeln('исходные:');
for i:=1 to max do 
begin   
a[i]:=random(2);   
write(a[i]:4);   
end;
for i:=1 to 15 do
begin   
if a[i]=0 then inc(k0) else inc(k1);   
if a[i]<>0 then k:=true; 
if k=false then inc(k3);
end;   
writeln;   
writeln('количество нулей = ',k0);   
writeln('количество единиц = ',k1);   
writeln('количество нулей до первой единицы = ',k3);   
End.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, которая осуществляет ввод в массив с клавиатуры размер 5 файлов в байтах ( от 100 до 9000 байт) и преобразует значения, превышающие 1024 байт, в килобайты.результат выводится в строку. в pascal abc
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Tipan77
ellyb106786
natakrechko
zadvornovakrmst
Найти cа:= 31b:= 6c:= a mod b+b​
s-food
yurkovam-037
Татьяна Гришаевич
Lyalikova
oknacrow
preida-2
larson96
osandulyak
perminovaea
Матфеопуло1006
marani2