cmenick29
?>

Начал изучать python и захотел составить программу, которая проверяет делимость на 2. как сделать так что бы вводить число, а не две цифры. a = input("введите первую цифру") b = input("введите вторую цифру") c = a * 10 + b * 1 if c % 2 == 0: print ('nice'); else: print('bad')

Информатика

Ответы

yfetyukov2
Не очень понял проблему. Python легко воспринимает числа. Единственное что input возвращает значение строки. Поэтому вполне логично было бы написать:
a=int(input("введите значение а"))
Но здесь есть некоторые проблемы. Если пользователь введет символы, которые нельзя преобразовать в int, выдаст ошибку. Для этого надо ставить проверку. Самый простой через конструкцию try - except. Но это уже совсем другая история...
apetrov13
Как-то так
#include <iostream>
using namespace std;
int main(){    cout << "Vvedute kol-vo ocenok" << endl;
    int n,i,a,Four,Five;    n = i = a = Four = Five = 0;
    cin >> n;
    for (i = 1; i <= n; i++)    {        cin >> a;        if (a == 4){         Four++;}  else if (a == 5)      {         Five++;      }    }    if (Four > Five){   cout << "Four" << endl;} else if (Five > Four)      {   cout << "Five" << endl;      }      else      {         cout << "Equal"<< endl;      }      cout << "Kol-vo 4: " << Four << " Kol-vo 5: " << Five << endl;    return 0;}
staskamolbio5152
В начале мы создаем массив случайных элем.
Потом работаем с ним.
Нам нужны 2 переменные:
1 - переменная, для сохранения результата (номера).
2 - переменная флажок.
Мы обходим весь массив ПО СТОЛБЦАМ.
В начале обхода конкретного столбца переменной флажка присвоим 1.
Сравниваем текущий элемент столбца с последующим,
если они не равны то ставим флажок 0

Код:
//Размерность массива
const n = 3;
//Сам массив
var 
ar : array[1..n,1..n] of integer;
//Переменные для работы с массивом
var 
i,j : integer; 
//Переменные для поиска столбца
//f - переменная флажок, которая по окончанию обхода столбца будет
//показывать одинаковы ли элементы в нем
//numb - переменная, в которой сохраним номер столбца с
//одинаковыми значениями элементов.
var 
f,numb : integer;
begin
//Создание и вывод на экран массива
//Элементы генерируются случайным образом
//  
for i:=1 to n do 
begin   
for j:=1 to n do   
begin     
ar[i,j] := random(2);     
write(ar[i,j]:3);   
end;   
writeln;   
end;  
// 

//Вот сам алгоритм поиска
//
//Записываем в numb значение -1
//Если в процессе работы значение не изменится (-1)
//То означает, что в массиве нет одинаковых столбцов
  numb := -1; 

//Идем по массиву
//
for j:=1 to n do
//Момент начала конкретного j столбца  
  begin    
//записываем в f значение 1
  //Предполагаем, что столбец одинаков
  //Если в конце обхода конкретного столбца значение f=1
  //Значит, что данный столбец одинаков
  f := 1;    
 
//Идем по столбцу
// n-1
//(т.к сравниваем текущий со следующим)
for i:=1 to n-1 do   
begin  
//Сравниваем текущий элемент столбца, со следующим     
if (ar[i,j] <> ar[i+1,j]) then
    //Если они не равны, то изменяем значение флажка f на 0       
    f := 0;   
end; 
//Конец обхода конкретного столбца  
 
//Если столбец одинаков   
if (f = 1) then
    //то записываем его номер в numb     
    numb := j;  
end;  
//  

//Вывод результата 
if (numb <> -1) then   
writeln('Столбец №: ',numb) 
else   
writeln('Нет ни одного одинакового столбца');    
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Начал изучать python и захотел составить программу, которая проверяет делимость на 2. как сделать так что бы вводить число, а не две цифры. a = input("введите первую цифру") b = input("введите вторую цифру") c = a * 10 + b * 1 if c % 2 == 0: print ('nice'); else: print('bad')
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

margarita25061961
panstel
LesnovaVeronika1830
Komarovsergeysk
aivanova
mv7095
Рогова Ольга1156
Сергеевна-С.А.1549
kolesnikovaen
elena-novikova-1992
OlgaVasilevna
strager338
info4632
bergamon
Щуплова Александр