?>
Информатика python. написать программу 1. запросить пользователя ввести имя файла(файл содержит числа) если файл не существует - выдать ошибку, завершить программу 2. создать пустой список.прочитать файл.удалить \n значения.перевести все в вид integer. присоеденить форматированный файл к списку. если в строчке нет числа - пропустить и читать следующую строчку выписать наибольшее число списка.либо выдать ошибку о пустом списке. файл сохранить в формат csv. таким образом : (число; число - наибольшее значение списка)
Ответы
function otr(ax, bx, ay, by: real) : =
sqrt(sqr(bx - ax) + sqr(by - ay));
begin
var ax, ay, bx, by, cx, cy, dx, dy: real;
readln(ax, ay, bx, by, cx, cy, dx, dy);
writeln('|ab|=', otr(ax, bx, ay, by));
writeln('|ac|=', otr(ax, cx, ay, cy));
writeln('|ad|=', otr(ax, dx, ay, dy))
end.
пример 2.3 3.09 -4.2 6 8.5 -3 4 0 |ab|=7.12166413136705 |ac|=8.69069042136469 |ad|=3.52676905963518