program ;
var
i, a: longint;
x,
u, j,
n, m : longint;
function fdiv (a, left : longint) : longint;
var
d,
i : longint;
begin
d : = 1;
for i : = left to trunc (sqrt (a)) do
if (a mod i = 0)
then
begin
d : = i;
break;
end;
if (d < > 1)
then
fdiv : = d
else
fdiv : = a;
end;
function g (n, u : longint) : longint;
var
i : longint;
begin
i : = 0;
while (n mod u = 0)
do
begin
inc (i);
n : = n div u;
end;
g : = i;
end;
begin
assign (input, 'input.txt');
assign (output, 'output.txt');
reset (input);
read (a);
close (input);
m : = 0;
n : = 1;
i : = fdiv (a, 2);
u : = 2;
while (a > 1)
do
begin
n : = n * i;
j : = 0;
while (a mod i = 0)
do
begin
inc (j);
a : = a div i;
end;
if (j > m)
then
begin
m : = j;
u : = i;
end;
i : = fdiv (a, i + 2);
end;
x : = 1;
while (g (n * x, u) * n * x < m)
do
inc (x);
n : = n * x;
rewrite (output);
write (n);
close (output);
end.
Задание 1.
Локальная сеть представляет собой объединение компьютеров, расположенных на небольших расстояниях друг от друга.
Задание 2.
Обычно компьютеры ЛС удалены друг от друга на расстояние не более 1 км
Задание 3.
ЛС предоставляют пользователям возможность не только быстрого обмена информацией, но и совместного использования принтеров и других периферийных устройств и даже одновременной работы с документами
Задание 4.
Основой программного обеспечения ЛС является сетевая операционная система. Важнейшая задача сетевой ОС — поддержка такого режима работы ЛС, чтобы работающие в ней пользователи могли использовать общие ресурсы сети и при этом не мешали бы друг другу.
Задание 5.
Одноранговая, децентрализованная, или пиринговая сеть — это оверлейная компьютерная сеть, основанная на равноправии участников.
Задание 6.
Сервер — специализированный компьютер или специализированное оборудование для выполнения на нём сервисного программного обеспечения.
Задание 7.
Рабочая станция — комплекс аппаратных и программных средств, предназначенных для решения определённого круга задач.
Поделитесь своими знаниями, ответьте на вопрос:
Даны целые числа a, b, c. написать программу, подсчитывающую сумму тех из данных чисел, которые больше нуля.
program n1;
var a,b,c,s:integer;
begin
readln (a);
readln (b);
readln (c);
s:=0;
if (a>0) then
s:=s+a;
if (b>0) then
s:=s+b;
if (c>0) then
s:=s+c;
writeln (s);
end.