bksenia9775
?>

Паскаль массив составить программу имеется массив в11 из целых чисел. найти количество элементов массива, больших числа 2 и кратных 3

Информатика

Ответы

nngudkova1970
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var b:=ArrRandom(11,-50,50); b.Println;
  Writeln('k=',b.Where(x->(x>2) and (x mod 3=0)).Count)
end.

Пример
2 -10 -31 39 18 -35 -24 -22 4 -31 30
k=3
Simbireva

Попробуйте так:

1) 25 + 22 - 33 = 14 (учеников) - читали книги Пушкина и Лермонтова,

2) 25 + 22 - 31 = 16 (учеников) - читали книги Пушкина и Гоголя,

3) 22 + 22 - 32 = 12 (учеников) - читали книги Гоголя и Лермонтова,

4) 25 + 22 + 22 - 14 - 16 - 12+10 = 37 (учеников) - читали книги хотя бы одного из этих писателей ,

5) 40 - 37 = 3 (ученика) - не знакомы с произведениями этих писателей,

6) 25 - 16 - 14 + 10 = 5 (учеников) - читали книги только Пушкина,

7) 22 - 16 - 12 + 10 = 4 (ученика) - читали книги только Гоголя,

8) 22 - 14 - 12 + 10 = 6 (учеников) - читали книги только Лермонтова,

9) 5 + 4 + 6 = 15 (учеников) - прочли книги только одного из этих авторов.

ответ. 3 ученика не знакомы с произведениями этих писателей; 15 учеников прочли книги только одного автора.

Марюк-Мубариз
1)
program average;
var
    i: integer;
    answer, S, tmp: real;
begin
    for i := 1 to 5 do
    begin
        readln(tmp);
        S := S + tmp
    end;
    answer := S / 5;
    writeln(answer)
end.
2)
program equation;
var
    A, B, C, D, x1, x2: real;
begin
    writeln('ввеедите коэфициенты квадратного многочлена');
    readln(A);
    readln(B);
    readln(C);
    if A <> 0 then 
    begin 
    D := B*B - 4*A*C;
    if D < 0 then
        writeln('действительных корней нет')
    else if D = 0 then
    begin
        x1 := -B/(2*A);
        writeln('Единственный корень: ',x1)
    end else
    begin
        x1 := (-B + sqrt(D)) / (2*a);
        x2 := (-B - sqrt(D)) / (2*a);
        writeln('Два корня: ',x1,', ',x2)
    end;
    end
        else writeln('старший коэфициент не может равняться 0')
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Паскаль массив составить программу имеется массив в11 из целых чисел. найти количество элементов массива, больших числа 2 и кратных 3
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

garunkhachatryan
Lorvi_Shevkunova849
merzlikinairena
inris088
aidapiltoyan43
o-pavlova-8635
Александрович Владимирович
Какой году был втарой война​
zorinka777
Buninilya
vrn3314
Nadegdasb
Попов1946
sleek73
Vadim443
dp199088206
▲