salahovta
?>

1. написать программу которая ищет n! (цикл while)2. написать программу, которая находит число р = (1-1/2)(1-1/3)**(1-1/n n вводится с клавиатуры. (цикл for)

Информатика

Ответы

komolovda

ответ:

объяснение:

1.

var

  k: integer;

  p: integer;

  n: integer;

begin

  readln(n);

 

  p: =1;

  k: =1;

 

  while (k < = n) do begin

    p: =p*k;

    k: =k+1;

  end;

 

  writeln(p);

 

end.

2.

var

  k: integer;

  p: real;

  n: integer;

begin

  readln(n);

 

  p: =1;

 

  for k: =2 to n do begin

    p: =p*(1 - (1/k));

  end;

 

  writeln(p);

 

end.

gutauta6
Сделал по условию, которое понял. var  a: array[1..3, 1..6] of integer;   i, j: integer; begin  writeln('введите 6 чисел через enter ');   for i : = 1 to 3 do    for j : = 1 to 6 do      case j of        1, 4: begin readln(a[i, j]); a[i, j] : = 2 * a[i, j]; end;         2, 5: a[i, j] : = sqr(i + j - 1);         3, 6: a[i, j] : = j mod 2;       end;   writeln('сформированный массив ');         for i : = 1 to 3 do    begin    for j : = 1 to 6 do      write(a[i, j], ' ');     writeln; end; end.
akopsiroyan
//pascal abc.net v3.0 сборка 1111 var   ma: array[1..15,1..2] of integer;   i,j,min: integer; begin;   randomize;   min: =2147483647;   for i: =1 to 15 do   begin;     writeln;     for j: =1 to 2 do       begin;       ma[i,j]: =random(100);       write(ma[i,j]: 4);       end;   if (ma[i,1]+ma[i,2])< min then min: =ma[i,1]+ma[i,2];   end;   writeln;   writeln('min=',min);   end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1. написать программу которая ищет n! (цикл while)2. написать программу, которая находит число р = (1-1/2)(1-1/3)**(1-1/n n вводится с клавиатуры. (цикл for)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

DmitrievnaVera
Кирилл-Анна1023
evsyukov1997
Екатерина15
romolga3580
Александровна1685
ski89439
mir5552
Olga-Borisovna
ognevasv555
energycomplect5914
Валуева
mmihail146
dddddd68
Кирилл_Гульницкий