gostivdom302
?>

Составьте программу на языке паскаль, с которой определите все четырехзначные номера машин, сумма двух двузначных чисел которых составляет 100

Информатика

Ответы

vikka30
Program kek;var a , b: real;i: integer;beginfor i := 1000 to 10000 dobegin    a := i mod 100;    b := i div 100;    if a + b = 100 then        writeln(i)end;end.
de1979nis
1) 40 * 60 1500 = 3600000 всего символов в книге
В стандартной кодировке 1 символ - 1 байт, значит
3600000 * 1 байт = 3600000 байт / 1024 = 3515,625 Кбайт / 1024 = 3,4 Мбайт
2) 1,25 Кбайт = 1280 байт = 10240 бит
10240 бит / 2048 символов = 5 бит -  глубина кодирования 1 символа
N = 2^i
N = 2^5 = 32 символа в алфавите
3) Использован двоичный код, значит 1 символ несет 1 бит информации
4) В русском алфавите 33 буквы - N
N = 2^i
33 = 2^i
i = 6 бит - несет 1 буква информации в русском алфавите
В слове математика 10 букв
10 * 6 бит = 60 бит информации несет слово МАТЕМАТИКА
5) N = 2^i
16 = 2^i
i = 4 бит несет 1 буква информации в 16-символьном алфавите
512 символов * 4 бит = 2048 бит / 8 = 256 байт = 0,25 Килобайт составляет это сообщение
6) 3 * 25 * 60 = 4500 всего символов
1125 байт *  8 = 9000 бит все сообщение
9000 / 4500 = 2 бита - 1 символ
N = 2^i = 2^2 = 4 символа в этом алфавите
7) N = 2^i
32 = 2^i
i = 5 бит - 1 символ
256 * 5 = 1280 бит информационный объем всего сообщения
1280 бит / 8 = 160 байт / 1024 = 0,15625 Килобайт
8) 0,5 Кбайт = 4096 бита - информационный вес сообщения
4096 / 2 = 2048 бит - на одной странице
2048 / 256 = 8 бит используется для кодирования 1 символа
N = 2^i = 2^8 = 256 симовлов в алфавите
9) N = 2^i
256 = 2^i
i = 8 бит  = 1 байт глубина кодирования 1 символа
30 * 70 * 5 = 10500 символов всего
10500 символов *  1 байт = 10500 байт все сообщение
10500 байт / 1024 = 10,25 Килобайт - все сообщение
10) N = 2^i
256 = 2^i
i = 8 бит  = 1 байт глубина кодирования 1 символа
1/32 Мбайт = 32 Кб = 32768 байт
32768 байт / 1 байт = 32768 символов в тексте
ea-office
Если данное уравнение не имеет корней, выведите число 0. Если уравнение имеет один корень, выведите число 1, а затем этот корень. Если уравнение имеет два корня, выведите число 2, а затем два корня в порядке возрастания. Если уравнение имеет бесконечно много корней, выведите число 3.
program gt;
var a,b,c,d,x1,x2,s:real;label 1,2;
begin
read(a,b,c);
if ((a=0)and(b=0)and(c<>0)) then writeln(0);
if(a=0)and(b=0)and(c=0)then writeln(3);
if(a<>0)and(b<>0)and(c<>0)then begin
d:=b*b-4*a*c;
if (d<0)or((a=0)and(b=0)and(c<>0)) then writeln(0);
if d>=0 then begin
x1:=(-b+sqrt(d))/(2*a);
x2:=(-b-sqrt(d))/(2*a);
if x1=x2 then write(1,' ',x1);
if (x1<>x2)and(x1<x2) then write(2,' ',x1,' ',x2);
if (x1<>x2)and(x1>x2) then write(2,' ',x2,' ',x1);
end;
end;
if (a=0)and(b<>0)and(c<>0)then begin
x1:=-c/b;
write(1,' ',x1);
end;
if (a<>0)and(b=0)and(c<>0)then begin
if(-c/a>=0) then begin
x2:=sqrt(-c/a);
x1:=-sqrt(-c/a);
if (x1<>x2)and(x1<x2) then write(2,' ',x1,' ',x2);
if (x1<>x2)and(x1>x2) then write(2,' ',x2,' ',x1);
end;
if(-c/a<0) then writeln(0);
end;
if (a<>0)and(b<>0)and(c=0)then begin
x1:=0;
x2:=-b/a;
if (x1<>x2)and(x1<x2) then write(2,' ',x1,' ',x2);
if (x1<>x2)and(x1>x2) then write(2,' ',x2,' ',x1);
end;
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу на языке паскаль, с которой определите все четырехзначные номера машин, сумма двух двузначных чисел которых составляет 100
Ваше имя (никнейм)*
Email*
Комментарий*