parabolaspb
?>

Составьте программу , которая находит сумму четных чисел и произведение нечётных чисел в диапазоне от 1 до 10

Информатика

Ответы

Герасименко
Const   N = 10;   
var   a, S1, S2: Integer;   
i, Q1, Q2: Byte;   
begin   
S1 := 0; Q1 := 0;   
S2 := 0; Q2 := 0;  
writeln('Введите ', N, ' чисел:');   
for i := 1 to N do 
begin     
read(a);     
if a < 0 then 
begin      
S1 := S1 + a;       
inc(Q1)     
end;     
if a > 0 then 
begin       
S2 := S2 + a;       
inc(Q2)     
end;   
end;   
writeln;   
if Q1 > 0 then 
begin     
writeln('Сумма отрицательных чисел: ', S1);     
writeln('Количество отрицательных: ', Q1)   
end   
else 
writeln('Отрицательных нет');   
if Q2 > 0 then
begin     
writeln('Сумма положительных чисел: ', S2);     
writeln('Количество положительных: ', Q2)   
end   
else 
writeln('Положительных нет') 
end.
Смирнов-Оськина
Const   n = 50; // количество чиселvar   k: array [1..n] of integer;   i, j, n1, n2, minr, a, b: integer; begin   writeln(n, ' ', ': d');   a : = random(1000);   b : = random(1000);   minr : = 10000;   for i : = 1 to n do       k[i] : = a + random(b);   for i : = 1 to n do       for j : = 1 to n do           if ((abs(k[i] - k[j])) < minr) and (k[i] < > k[j]) then           begin               minr : = abs(k[i] - k[j]);               n1 : = i;               n2 : = j;           end;   writeln(n1, ' ', n2); end.
vifslafes
 другое арбуз почтизнаток  (469) в чем отличие информационных ресурсов от материальных? какие есть основные виды национальных информ. ресурсов? закрыт 5 лет назад в лидеры лучший ответ элявысший разум (175060) это виды:   библиотечные ресурсы  архивные ресурсы  научно-техническая информация  правовая информация  информация государственных (властных) структур  отраслевая информация  финансовая и информация  информация о природных ресурсах  информация предприятий и учреждений  на фоне продолжающегося рос­та производства новых видов товаров начался процесс увеличения доли информационных ресурсов по отношению к материальным. информационные ресурсы в различных формах стали самостоятель­ными объектами (идеи, технологии и ноу-хау, научная и техническая ) [2].  широкое распространение информационных ресурсов дало основание говорить о возникновении информационного общества. информационные ресурсы имеют качественное и принципиальное отличие от материальных, вследствие неприменимости к ним закона сохранения материи. отдавая информационный ресурс, лицо вовсе не лишается его, то есть может использовать его сколько угодно раз.  исследуя и оценивая новые информационные и интеллектуальные ресурсы, современные эконо­мисты, едва успевают их описать и дать некоторые характеристики.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу , которая находит сумму четных чисел и произведение нечётных чисел в диапазоне от 1 до 10
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Zeegofer
anitanemtsewa
asvirskiy26
vladexi
stmr29
dakimov
Espivak
ВладимировнаИП37
de1979nis
AndrukhovichKonovalov
Ruzalina_Svetlana1435
nv6634
zsa100
Анатольевич-Фатима
taksa6444