#include <iostream> #include <conio.h> using namespace std;int main() { setlocale(LC_ALL,"Russian"); int lep; cout << "\t\tЧетное/нечетное кол-во лепестков у ромашки\n\n" << endl; cout << "Введите, сколько будет лепестков у ромашки:\n"; cin >> lep; if(lep%2!=0) { cout << "У ромашки не четное кол-во лепестков!" << endl; } else { cout << "У ромашки четное кол-во лепестков!" << endl; } _getch(); return 0; }
Андрей_Станиславовна
26.11.2020
Можно воспользоваться вариантом Vladmor, он более легкий и подходит под эту задачу, но чтобы не повторяться, для разнообразности, предложу свой вариант.
1+3+5+7 это ничто иное как арифметическая прогрессия. Есть несколько формул суммы членов прогрессии, но под этот тип задачи подойдёт такая:
- это член последовательности с индексом 1, то есть первое число в ряду. d - это разность между двумя соседними членами, из большего вычитаем меньшее
n - это сколько всего членов
и так, у нас получается = 1 (в условии задачи сказано что первый подарок весит 1кг) d = 2 (в условии сказано что следующий подарок увеличивается на 2, ничто иное как разность) n = это переменная, она нам не известна, поэтому так и оставим. - это сумма веса всех подарков, в примере используется слово "weight" что в переводе "вес", поэтому подставим это слово.
И теперь подставим что у нас имеется. weight = weight =
В коде программу будет записано так weight = ( ( 2+2*(n-1) ) / 2)*n
Проверим, например у нас 5 детей, значит надо 5 подарков, это 1+3+5+7+9 = 25 Проверим формулу weight = ( ( 2+2*(5-1) ) / 2)*5 weight = ( ( 2+2*4 ) / 2)*5 weight = ( ( 2+8 ) / 2)*5 weight = ( 10 / 2)*5 weight = 5*5 weight = 25 Всё сходится.
Расписал подробно, чтобы всё было понятно Так же этот вариант подойдёт для других таких типовых задач, а вариант Vladmor подойдёт только в некоторых случаях, будь внимателен(на)
Anna389
26.11.2020
var h1,m1,n,d,p,h2,m2: integer; begin write('начало занятий (часы, минуты): '); readln(h1,m1); write('количество уроков: '); readln(n); write('длительность уроков: '); readln(d); write('длительность перемен: '); readln(p); m2:=m1+n*d+(n-1)*p; h2:=h1+m2 div 60; m2:=m2 mod 60; writeln('время окончания занятий: ',h2,' часов ',m2,' минут'); end.
начало занятий (часы, минуты): 9 30 количество уроков: 4 длительность уроков: 45 длительность перемен: 10 время окончания занятий: 13 часов 0 минут
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Заранее . составьте программу, определяющую четное или нечетное количество лепестков у ромашки.
#include <conio.h>
using namespace std;int main()
{
setlocale(LC_ALL,"Russian"); int lep; cout << "\t\tЧетное/нечетное кол-во лепестков у ромашки\n\n" << endl; cout << "Введите, сколько будет лепестков у ромашки:\n";
cin >> lep; if(lep%2!=0) {
cout << "У ромашки не четное кол-во лепестков!" << endl;
}
else {
cout << "У ромашки четное кол-во лепестков!" << endl;
} _getch();
return 0;
}