artmasterstyle
?>

Нужно составить программу, которая формирует массив с 16 случайных целых чисел от -20 до 20 и: находит элементы с нулевыми значениями

Информатика

Ответы

fshevxuzheva313
Не понял смысл задачи. 
Написал, вывод номера элементов равных 0.
Нужно составить программу,которая формирует массив с 16 случайных целых чисел от -20 до 20 и: находи
Vladimirovich58
#include <stdio.h>#include<stdlib.h>
int main(void){    int mas[16]; //массив со случайными числами    int i; //счетчик
    //заполнение массива случайными числами    for(i=0; i<16; i++)    mas[i] = -20+rand()%20;    printf("ishodny massiv");    for(i=0;i<16;i++)        printf("%d,",mas[i]);    printf("\n");
    printf("nomera elementov massiva ravnih nulu");    for(i=0;i<16;i++)    if (mas[i]==0) printf("%d",i+1);
return 0;}
germanleon

Программа:

program dividers;

var x, i, p: integer;

   y: array of integer;

function dividersOf(n: integer; includeNegative: boolean := false):array of integer;

var a: array of integer;

   i, k: integer;

begin

 k:= 1;

 if(n<0) then n:= n*(-1);

 for i:= 1 to n

   do if(n mod i = 0)

        then begin

               SetLength(a, k);

               a[a.Length-1]:= i;

               k:= k+1;

             end;

 if(includeNegative)

   then a:= a.Select(x -> x*(-1)).Sorted.ToArray+a;

 dividersOf:= a;

end;

begin

 readln(x);

 y:= dividersOf(x, true);

 p:= y.Length-2;

 i:= 0;

 writeln('Делители числа ', x, ':');

 repeat

   write(y[i], ', ');

   i:= i+1;

 until i=p;

 write(y[p+1], '.');

end.

Lidburg

Программа:

program dividers;

var x, i, p: integer;

   y: array of integer;

function dividersOf(n: integer; includeNegative: boolean := false):array of integer;

var a: array of integer;

   i, k: integer;

begin

 k:= 1;

 if(n<0) then n:= n*(-1);

 for i:= 1 to n

   do if(n mod i = 0)

        then begin

               SetLength(a, k);

               a[a.Length-1]:= i;

               k:= k+1;

             end;

 if(includeNegative)

   then a:= a.Select(x -> x*(-1)).Sorted.ToArray+a;

 dividersOf:= a;

end;

begin

 readln(x);

 y:= dividersOf(x, true);

 p:= y.Length-2;

 i:= 0;

 writeln('Делители числа ', x, ':');

 repeat

   write(y[i], ', ');

   i:= i+1;

 until i=p;

 write(y[p+1], '.');

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нужно составить программу, которая формирует массив с 16 случайных целых чисел от -20 до 20 и: находит элементы с нулевыми значениями
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

arammejlumyan
nkaminskaja
kirillboytsov403
citioil15
fastprofit
strager338
N-odes-art-school410
Korobeinikov-Yulich23
katya860531
zaalmix
kuhonka2021
Wlad967857
Aleksandrovna-Marina
ainud
Novikova Aleksandrovna
▲