kas80
?>

Решить в паскале abc 1)даны два различных вещественных числа. определить: а) какое из них больше; б) какое из них меньше. 2)считая, что земля - идеальная сфера с радиусом 6350 км, определить расстояние до линии горизонта от точки с высотой над землей, равной 1, . 3)дан массив. составить программу вычисления среднего арифметического двух любых элементов массива. 4)составить программу, определяющую длину самого короткого и самого длинного слова в тексте (разделитель слов - пробел

Информатика

Ответы

Mukhlaev-Olga
Все 4 задачи в файле "PAS" которые находятся под этим сообщением. Будут вопросы, задавайте в ЛС
zurabghiendzhoian886
{Данная программа переводит любое сочетание символов ASCII в систему счисления заданную пользователем.}

//Pascal ABC.NET v3.0 сборка 1111

var
 a,i,b,r,n,j,bug:integer;
 s,se,slo,slof:string;

procedure preob(var a,b,n:integer; var se:string);
 begin
  repeat
   b:=a mod n;
   a:=a div n;
   str(b,se);
   s+=se;
  until (a<=n-1);
 end;

beginreadln(slo);
readln(n);
for j:=1 to length(slo) do
begin;
a:=ord(slo[j]);
preob(a,b,n,se);
str(a,se);
s+=se;
for i:=1 to length(s) div 2 do
begin;
se:=s[i];
s[i]:=s[length(s)-i+1];
s[length(s)-i+1]:=se[1];
end;
write(s,'-');
slof:=slof+s;
delete(s,1,length(s));
end;
end.

Пример ввода:
Домашняя работа на завтра.
2
Пример вывода:
11000100-11101110-11101100-11100000-11111000-11101101-11111111-11111111-100000-11110000-11100000-11100001-11101110-11110010-11100000-100000-11101101-11100000-100000-11100111-11100000-11100010-11110010-11110000-11100000-101110-

{Таким образом, фразу "Домашняя работа на завтра." можно закодировать как "11000100-11101110-11101100-11100000-11111000-11101101-11111111-11111111-100000-11110000-11100000-11100001-11101110-11110010-11100000-100000-11101101-11100000-100000-11100111-11100000-11100010-11110010-11110000-11100000-101110-".}
baeva-larisa8165
Не особо знаю паскаль, так что дабы не накосячить с синтаксисом, покажу на примере. Тут всё просто - тебе лишь нужен цикл For и расчет процентов.

FOR i = 1 TO 100
percents = FIX(x * p / 100) ' здесь у нас есть переменная percents, которой присваиваются округленные функцией fix проценты (насколько я знаю, в паскале аналогичная функция называется Round)
x = x + percents 'тут всё понятно - переменной X присваивается она сама и годовые проценты по вкладу
IF x >= y THEN 'проверяем, не равен или не превысил ли наш вклад ожидаемую сумму
PRINT i 'в цикле For можно не заморачиваться с отслеживанием лет, переменная i сама подсчитает количество итераций-лет
END 'завершаем программу
END IF
NEXT i ' конец цикла
Можно ещё чисто для себя добавить в условие вывод переменной X, чтобы было нагляднее.  

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решить в паскале abc 1)даны два различных вещественных числа. определить: а) какое из них больше; б) какое из них меньше. 2)считая, что земля - идеальная сфера с радиусом 6350 км, определить расстояние до линии горизонта от точки с высотой над землей, равной 1, . 3)дан массив. составить программу вычисления среднего арифметического двух любых элементов массива. 4)составить программу, определяющую длину самого короткого и самого длинного слова в тексте (разделитель слов - пробел
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

gorsimonyan4
aprelevka
club-pushkin
sedalex
alexst123012225
petr2077
igraparkGP51
mariia39
ruslan
Анна1417
AleksandrIvanovich1273
Shteinbakh
colus77
Buninilya
aguliaeva
▲