vak1984
?>

Написать программу если в массиве (из n чисел) есть хотя бы одна тройка соседних чисел, в которой средний элемент больше своих "соседей", т. е. предшествующего и последующего, то напечатать все элементы, предшествующие элементам последней из таких троек.

Информатика

Ответы

Boyaris
Type mas=Array [1...100] of integer;
var i,n,itre:integer;
a:mas;
begin
readln(n);
for i:=1 to n
do read(A[i]);
for i:=2 to n-1
do if (A[i]>A[i-1]) and (A[i]>A[i+1])
then itre:=i;
for i:=1 to itre-2
do writeln(A[i]);
end.
aleksey270593

Объемы двух понятий исключают друг друга, но входят в третье более широкое.   1.     Суждение «Некоторые студенты учатся в МГЮА» является частноутвердительным, т.к. в нем присутствует частный квантор «некоторые» и  нет отрицательной частицы НЕ. Некоторые       студенты      учатся      в      МГЮА                    КВ                           S                          P                                             Некоторые S есть Р       I     S-  P+         Суждение  «Ни один студент не учится в МГЮА» является общеотрицательным, т.к. в нем присутствует общий квантор «ни один» и есть отрицательная частица  НЕ. Ни       один        студент      не       учится        в         МГЮА               КВ                              S                                     P                Ни один S не есть Р      Е      S+ P+       Суждения находятся в отношении противоречия и не могут быть одновременно не истинными не ложными  (Е – I).   4. Суждение «В здоровом теле здоровый дух» является  общеутвердительным. В    здоровом     теле     здоровый     дух                                                         S                                          P           Все  S  есть Р     А    S+  P-   5. Суждение  «Не верно, что Митя и Вася весь день просидели перед компьютером» является  противоречащим. Оно эквивалентно суждению «Митя и Вася  НЕ весь день просидели перед компьютером». По правилу частноотрицательных суждений  имеем «Некоторые S не есть Р». Митя  и  Вася   НЕ  весь  день  просидели  перед  компьютером                  S                                                            P      Некоторые  S  не есть Р     О    S- P+    

Объяснение:

iplizogub74

Объяснение:

Человек, как высшая ступень процесса эволюции природы, в борьбе за существование был вынужден при окружающий предметный мир к своим потребностям и преобразовывать его в процессе труда. Познавая свойства созданных природой материалов, человек обнаружил, что каждый из них имеет строго определенную форму и строение. Впоследствии стало понятным, что производимые человеком вещи смогут приобрести необходимую прочность и устойчивость тогда, когда они будут формироваться по законам природы.

Постепенно созданный людьми предметный мир не только совершенствовал их умственные и практические качества, но также запечатлевал их переживания, чувства, настроения. Эмоциональное воздействие предметного мира стало теснее связываться со значением вещи в повседневной жизни человека и с его физиологическими особенностями. Наш исторический предок заметил, что форма, соответствующая назначению вещи, вызывает у него приятные чувства. Такие качества, как свет или цвет, воспринимаются инстинктивно, доставляя удовольствие и наслаждение непосредственно; другие свойства выразительны в силу того, что лежат в основе деятельности организма человека – это ритм и симметрия.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу если в массиве (из n чисел) есть хотя бы одна тройка соседних чисел, в которой средний элемент больше своих "соседей", т. е. предшествующего и последующего, то напечатать все элементы, предшествующие элементам последней из таких троек.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

myxa120283
oldprince840
melnik-738
kashihina
aifbon
coffeenik20233
helenavalenti2846
Yeroshkina411
ЮлияДаниил520
Iprokopova81
alex091177443
bulk91675
Kuznetsova1639
ГусенковФролова1121
Strelkov567