nelli-bi6
?>

Напишите программу, которая вычисляет следующее значение. по теореме пифагора, в прямоугольном треугольнике соотношение сторон c2=a2+b2. если a=3, b=2, каково значение c? в pascal abc

Информатика

Ответы

alicia179
Program Teorema_P;
var    A, B, C: real;
begin
     writeln ('Введите значение первого катета:');
     readln (A);
     writeln ('Введите значение второго катета:');
     readln (B);
     C:=sqrt(A*A + B*B);
     writeln ('Катет А = ', A, ', катет В = ', B, ', гипотенуза С = ', C:5:3);
end.
Напишите программу, которая вычисляет следующее значение. по теореме пифагора, в прямоугольном треуг
Голосова-Лобанов1555
Var
A:array[1..12] of integer;
i:integer;
Begin
Write('Исходный массив: ');
For i:= 1 to 12 do
    Begin
    A[i]:=random(21)-10;
    Write(A[i],' ');
    End;
WriteLn;
Write('Чётные элементы: ');
For i:= 1 to 12 do
    if A[i] mod 2 = 0 then Write(A[i],' ')
End.

Var A:array[1..10] of integer;
i:integer;
Begin
Write('Исходный массив: ');
For i:= 1 to 10 do
    Begin
    A[i]:=random(21)-10;
    Write(A[i],' ');
    End;
WriteLn;
Write('Обработаный массив: ');
For i:= 1 to 10 do
    Begin
    if A[i] mod 10 = 0 then A[i]:=0;
    Write(A[i],' ')
    End;
End.
serg1976g
«Кто владеет информацией — тот владеет миром», — был убежден премьер-министр Великобритании Уинстон Черчилль, и вряд ли его можно упрекнуть в заблуждении. Обычно в качестве иллюстрации этого тезиса приводят пример с рыбалкой, когда знание о том, где можно наловить много рыбы, ценится выше, чем удочка. Увы, с тех пор, как британский премьер изрек бессмертные слова немало времени, и фигуральная вода, в которой водятся пресноводные, успела порядком помутнеть. На сегодняшний день информации в мире стало так много, что скорее уж миром владеет тот, кто владеет дезинформацией. А все остальные вынуждены бороться с информационными вирусами самостоятельно.
Автор: Глядящий Вдаль 

Фильтрующие программы: Из данных министерства связи следует, что несмотря на то, что многие родители в Израиле очень обеспокоены данной ситуацией, только 53% родителей считают интернет небезопасным местом, 67% родителей позволяют своим детям беспрепятственно пользоваться интернетом, а 53% родителей вообще не вмешиваются в то, каким образом их дети пользуются интернетом. Важно знать, что сегодня существуют программы, которые фильтруют информацию в интернете. Эти программы рассчитаны как на личный компьютер, так и на мобильный телефон. Они фильтруют оскорбительную и опасную для детей информацию, такую как порнография, тяжелое насилие и продажа наркотиков, и препятствуют тому, чтобы дети передавали свои личные данные, которые могут нанести вред им самим или их окружающим, не мешая при этом обычному пользованию интернетом и не замедляя работу компьютера. Эти программы легко достать и установить. Более того, по закону поставщики интернет услуг, включая операторов мобильной связи, обязаны предлагать своим абонентам эффективные услуги по фильтрации интернет сайтов и оскорбительной информации без дополнительной платы.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая вычисляет следующее значение. по теореме пифагора, в прямоугольном треугольнике соотношение сторон c2=a2+b2. если a=3, b=2, каково значение c? в pascal abc
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

krasa28vostok65
Sharap
len22
алексей-Ветошкин
amramzi
satinvova
komarov-dmitriy
apromovich1
bondarev05071962
mariy-inkina8
aleksandramir90
ninaandreeva3179
kagurkina
frsergeysavenok
chuykin
▲