ganul
?>

24 . даны три числа. составьте программу, которая вычисляет кубическую степень отрицательных среди этиз чисел

Информатика

Ответы

obitelsvel8
Var
a:array [1..3] of integer;
i:integer;
begin
for i:=1 to 3 do read(a[i]);
for i:=1 to 3 do 
if a[i]<0 then write(a[i]*a[i]*a[i],' ');
end.
annapiskun1

Информáтика (фр. Informatique; англ. Computer science) — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений[1].

Информатика включает дисциплины, относящиеся к обработке информации в вычислительных машинах и вычислительных сетях: как абстрактные, вроде анализа алгоритмов, так и конкретные, например разработка языков программирования и протоколов передачи данных.

Темами исследований в информатике являются вопросы: что можно, а что нельзя реализовать в программах и базах данных (теория вычислимости и искусственный интеллект), каким образом можно решать специфические вычислительные и информационные задачи с максимальной эффективностью (теория сложности вычислений), в каком виде следует хранить и восстанавливать информацию специфического вида (структуры и базы данных), как программы и люди должны взаимодействовать друг с другом (пользовательский интерфейс и языки программирования и представление знаний) и т. п.

grigoriev8
1) Работает 6 часов по полчаса - 12 пациентов. Кодируется int(log2 12) = 4 битами. 2) 32 буквы кодируются 5 битами (log2 32). В слове «муравей» 6 букв. 6 * 5 = 30.3) 8*8 = 64. log2 64 = 6. Именно столько бит необходимо для кодирования каждой клетки.4) Что подразумевается под «оптимальным» не знаю, так что затрудняюсь ответить.5) log2 64 = 6 - количество бит для кодирования символа. 2000 * 6 = 12000 - количество бит для кодирования текста. 12000 / 8 = 1500 - количество байт для кодирования текста.6) 300 / 150 = 2 байта на символ. 2 * 8 = 16 бит. 2^16 = 65536. В алфавите не более 65536 символов7) Если кодировка ASCII или другая с кодированием в 1 байт на символ, то да, т.к. в килобайте 1024 байт. Если Unicode или подобные с 2-байтовой кодировкой, то нет/8) 5000 / 10 = 500 - байт  = 4000 бит в секунду. 800 - символов в секунду. 5 бит на символ. 2^5 = 32 символа9) 2,5 = log2 32 / log2 x. Получаем, что x = 410) один 8-ричный разряд содержит 3 бита (log2 8), 3 разряда числа - 3 * 3 = 9

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

24 . даны три числа. составьте программу, которая вычисляет кубическую степень отрицательных среди этиз чисел
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ehrik-ch
kassel1b
Lomakina-Valerievna1779
nurtilekisakov
Kochereva-Sergei
ivanda
artbogema2016
Ka-shop2791
narkimry134
filippovev1
olimov9
pelagia-kola2658
Elshel8694
marketing
shoko-2379