mariya
?>

Pascal, цикл для, составить программу ввести целое число n. найти сумму первых n чётных натуральных чисел.

Информатика

Ответы

Minchenkova
Var n,i,s:integer;
begin
write('n = ');
readln(n);
s:=0;
for i:=1 to n do s:=s+2*i;
writeln('s = ',s);
end.

Пример:
n = 5
s = 30
kashihina
#include <iostream>
using namespace std;
int main()

   for(int i = 10; i < 100; i++) 
  {     
          if(i/10 == 2*(i%10))   
              cout << i << " ";
   }   
           return 0;
}
Пример на С++ 
Но если надо на другом языке, то суть такова:
1)запускаешь цикл от 10 до 99(все двузначные числа) со счетчиком i например
2)внутри условие если i деленный нацело на 10(1 цифра этого числа )равен  удвоенному значению остатка от деления i на 10 ( последняя цифра числа в 2 раза больше 1 должна быть)
то на экран выводится это число i 
migreen
#include <iostream>
using namespace std;
int main()

   for(int i = 10; i < 100; i++) 
  {     
          if(i/10 == 2*(i%10))   
              cout << i << " ";
   }   
           return 0;
}
Пример на С++ 
Но если надо на другом языке, то суть такова:
1)запускаешь цикл от 10 до 99(все двузначные числа) со счетчиком i например
2)внутри условие если i деленный нацело на 10(1 цифра этого числа )равен  удвоенному значению остатка от деления i на 10 ( последняя цифра числа в 2 раза больше 1 должна быть)
то на экран выводится это число i 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Pascal, цикл для, составить программу ввести целое число n. найти сумму первых n чётных натуральных чисел.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kolgatin69
oyudina
lugowskayatania2017
Захаров-Иванович
Corneewan
Lugovoi
eizmaylova6
dumpler
polusik120796
denisdenisov63
ti2107
ekb676
maltes
mikhailkirakosyan
Larisa Bulgakova