vadim1140
?>

Нужно составить программу на паскале: дано три числа. найти количество положительных чисел среди них

Информатика

Ответы

verich
Var
  a,b,c:real;
  k:integer;
begin
  Write('Введите три числа через пробел: '); Read(a,b);
  k:=0;
  if a>0 then Inc(k);
  if b>0 then Inc(k);
  if c>0 then Inc(k);
  Writeln('Количество отрицательных чисел ',k)
end.

Пример
Введите три числа через пробел: 23.5 -24 0
Количество отрицательных чисел 1
Rakitin
Program zadacha;

var

a: array[1..3] of real;

i,k: integer;

begin

k:=0;

writeln('vvedite 3 chisla');

for i:=1 to 3 do read(a[i]);

for i:=1 to 3 do begin

if a[i]>0 then k:=k+1;

end;

writeln('kol-vo polojit.chisel =',k);

end.

Нужно составить программу на паскале: дано три числа. найти количество положительных чисел среди них
dmitrymakarov003

1. Количество чисел в последовательности вводится пользователем

var n,i,a,k: integer;

begin

write('Введите количество чисел в последовательности ');

readln(n);

for i := 1 to n do

begin

write('Введите число: ');

readln(a);

if a mod 10 = 5 then k:=k+1

end;

writeln('Количество чисел заканчивающихся на 5 равно ',k)

end.

2. Признак окончания последовательности ввод 0 (цикл while)

var a,s:integer;

begin

write('Введите число: ');

readln(a);

while a<>0 do

begin

if(a mod 4 = 0) and (a mod 10 = 8) then s:=s+a;

write('Введите число: ');

readln(a)

end;

writeln('Сумма чисел кратных 4 и заканчивающихся на 8 равна ',s)

end.

3. Признак окончания последовательности ввод 0 (цикл repeat)

var a,k,s: integer;

begin  

repeat

write('Введите число: ');

readln(a);

if a mod 2 = 0 then

begin

k:=k+1;

s:=s+a

end

until a=0;

writeln;

writeln ('Среднее арифметическое четных чисел равно ',s/k)

end.

Ludmila777020

Мне известны такие системы программирования:

Паскаль, джава, фортран.

Паскаль наиболее известный язык программирования, используется  для обучения программированию в старших классах.

Джава - язык программирования. Разработанный компанией  Sun Microsystems (американская компания). Программы на Java транслируются в байт-код Java, выполняемый виртуальной машиной Java (JVM) — программой, обрабатывающей байтовый код и передающей инструкции оборудованию как интерпретатор.

Фортран - язык программирования, получивший практическое применение, имеющий транслятор и испытавший дальнейшее развитие.

Фортран имеет большой набор встроенных математических функций, поддерживает работу с целыми, вещественными и комплексными числами двойной и повышенной точности, имеет богатый инструментарий работы с массивами и внешними файлами.

Соррян если надо больше

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нужно составить программу на паскале: дано три числа. найти количество положительных чисел среди них
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ynikolaev2657
Дмитриевич Бирковская69
s-laplandia6
Yuliya
juli19657
Shcherbinin KOLIChEVA
kortikov77
TSKaraulova
turoverova5
dfyurst708
infocenterbla
Vasilevich Fokin
mariia39
M10M11M12
Присакарь520
▲