molchanovaelena284
?>

Сделать, заранее ! имеется четыре произвольных числа(abcd составить программу на алгоритм чеком языке програмирования, анализирующую эти числа и отвечающую на вопрос: правда ли, что последнее число самое большое?

Информатика

Ответы

porotikova1004
Program one;
Uses CRT;
Var a,b,c,d:real;
If (b>a) and (b>c) and (b>d) then writeln('последнее число большее');
Else writeln('последнее число не самое большое');
End.
people33

Объяснение:

1.

Определяем количество символов в сообщении, для этого количество символов умножаем на количество страниц:

128 х 4 = 512 символов.

Находим сколько информации отводится на кодирование 1 символа:

0,125 Кбайт х 1024 = 128 байт или 128 х 8= 1024 бита всего в сообщении

1024 бита : 512 символов = 2 бита на 1 символ

Находим количество символов в алфавите по формуле N = 2^i:

N=2²=4

Мощность алфавита составляет 4 символа.

2.

Количество пирожков с вишней К1=2

Всего пирожков в корзине N=4+10+2+4=20

Вероятность выбора пирожка с вишней составляет

р1=К1/N=2/20=0,1

Теперь вычислим количество информации, содержащееся в сообщении, что Маша выбрала пирожок с вишней:

I1=log₂ (1/р1)=log₂(1/0,1)=log₂ 10=3,322 бита ≈4 бита (поскольку бит- минимальная единица информации и число бит не может быть дробным)

3.

2^i=N, где N - объём информации, а i - кол-во бит, которым кодируется единица информации. N=15*5=75

2^i=75

i=log₂ 75=6,23 бита ≈ 7 бит

mail5

Объяснение:

1. int x = 340;

int ind = x.Substring(0,1);

2. int[] arr = new arr[5];

int prod = 1;

int count;

foreach (int el in arr) prod*=el; count++;

3. int[] numbers= new numbers[N];

int min = numbers[0], minIndex = 0;

for (int i = 0; i < NumbersCount; i++) { if (min > numbers[i]) { min = numbers[i]; minIndex = i; } }

4. int ded = M;

int vnyk=N;

int res =vnyk*3;

задача бессмысленна. он уже старше внука в 3 раза, как минимум

5. string name = Console.ReadLine();

string surname = Console.ReadLine();

string thirdName = Console.ReadLine();

Console.WriteLine(name+" "+surname);

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Сделать, заранее ! имеется четыре произвольных числа(abcd составить программу на алгоритм чеком языке програмирования, анализирующую эти числа и отвечающую на вопрос: правда ли, что последнее число самое большое?
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

tatianamatsimoh
Александра-Андрей909
Усошина1059
Александр734
ali13zakup5064
tarasova
monenko
Wunkamnevniki13438
mvinogradov6
ocik1632933
andr77716
sergeykvik13
mmreznichenko
vladimir152
Busyashaa