Поделитесь своими знаниями, ответьте на вопрос:
На c++ требуется написать программу, которая определяет цифры исходного четырёхзначного числа x и выводит их на экран. формат входных данных входной поток содержит целое число x (1000≤x≤9999) формат выходных данных выведите цифры числа xx по одному в строке, в следующем порядке: тысячи, сотни, десятки и затем единицы.
using namespace std;
int main()
{
int a, b;
cout << "a = ", cin >> a, cout << "\n";
b = a/1000;
cout << b << "\n";
b = a/100 % 10;
cout << b << "\n";
b = a % 100 / 10;
cout << b << "\n";
b = a % 10;
cout << b << "\n";
return 0;
}
Пример:
a = 7052
7
0
5
2