ALLA1868
?>

Напишите программу для вычисления значения функций на паскале {nx^2-7/x^2 a< 1 y= {ax^3+7√x a=1 {ln(x+7√x+a) a> 1

Информатика

Ответы

Манько_Панферов
Var x,y:real;
begin
writeln ('Введи х');
readln (x);
y:=7*x*x-3*x+6;
writeln ('y=',y:5:2);
end.
slavutich-plus2
По распоряжению алфавит должен состоять из четырех символов; А, Б, В. Г, поэтому запись любого числа с этого алфавита - это его представление в системе счисления по основанию 4.
Чтобы лучше понять эту идею, вспомним привычную нам запись чисел - десятичную. Она называется десятичной потому, что для записи чисел в ней используются десять знаков - от 0 до 9. Знаков десять и в соответствии с этим числа, ими записанные представляются в десятичной системе счисления. А если у нас таких знаков только восемь - от 0 до 7? Совершенно верно, это алфавит восьмеричной системы счисления. А если только два знака в алфавите - 0 и 1? Да, мы приходим к той самой двоичной системе.

Теперь, когда мы обосновали выбор системы счисления по основанию 4. посмотрим, сколько разрядов нам надо для представления самого большого из требуемых чисел - числа 49. Почему 49, а не 50, ведь мест 50? Да, мест 50, но они нумеруются от 1 до 50, а мы будем их кодировать числами от 0 до 49. Для "экономии" - чего нулю пропадать даром?
Переводим 49 в систему счисления по основанию 4. Тем самым делим на основание системы, пока есть что делить, т.е. пока не получим 0 в целой части.
49 / 4 = 12 и 1 в остатке.
12 / 4 = 3 и 0 в остатке
3 / 4 = 0 и остаток 3.
А теперь записываем остатки в обратном порядке: 301.
Итак, 49₁₀ = 301₄
Следовательно, нам достаточно иметь три разряда для записи номера любого места.
Осталось вспомнить, что вместо цифр 0,1,2,3 (а именно они составляют алфавит системы счисления по основанию четырые) мы должны писать буквы, да еще и в алфавитном порядке. Ну и ладно, тогда пусть так будет:
А - 0, Б - 1, В-2, Г-3. И наш максимальный номер 49₁₀ = 301₄ запишется в виде ГАБ.
А как закодировать место 49? Оно лишь на 1 меньше, чем максимальное 50, но 50 это у нас 301₄. отнимем 1 и получим 300₄, которое кодируется как ГАА. Это и есть ответ.
VEZZDEXOD73
1) 8 страниц * на 72 строки * 48 символов = 27648 символов - общий объем статьи.
2) информационный объем будет равен количеству символов умноженному на размер кодировки для символа, т.е. 27648 * 8 = 221184 бита.
3) Так как в вариантах ответа есть объем в Кбайтах и в Кбитах, то считать нужно и в байтах и в битах соответственно.

221184 бит  - вариант №3 отпадает сразу
221184 бит / 1024 = 216 Кбит - наш ответ
221184 бит /8 = 27648 байт - отпадает вариант №2
221184 бит /8 = 27648 байт / 1024 = 27 Кбайт - отсекает вариант №1

Таким образом правильный ответ 4) 216 Кбит

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу для вычисления значения функций на паскале {nx^2-7/x^2 a< 1 y= {ax^3+7√x a=1 {ln(x+7√x+a) a> 1
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

buyamel
Вайнер
apetrov54
БеляковаСтаниславовна
julya847
Voronov434
Ivanovich_Kostik898
vettime625
klimenko05
Anatolevich-sergeevna
Чиркина999
krispel9
vvk2008
YaroslavSerganYS5
didizain
▲