Коваль1974
?>

Написать программу, которая - вводит в компьютер с клавиатуры годовые оценки к учеников класса; - подсчитывает и выводит на экран среднюю оценку в классе; - подсчитывает и выводит на экран количество учеников, у которых оценка выше средней.

Информатика

Ответы

mila-vsv
// PascalABC.NET 3.2, сборка 1377 от 19.01.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var k:=ReadInteger('k=');
  var a:=ReadArrInteger('Вводите оценки:',k);
  var m:=a.Average;
  Writeln('Средняя оценка по классу: ',m:4:2);
  Writeln('Учеников с оценкой выше средней: ',a.Where(x->x>m).Count)
end.
kashihina

Відмінності виконання повного і неповного розгалуження: 1) обчислюється значення логічного виразу, якщо це значення істинне (True), то у повному розгалуженні виконується послідовність команд і після цього виконується команда, наступна за розгалуженням, а у неповному — виконується послідовність команд і після цього виконується команда, наступна за розгалуженням; 2) якщо це значення хибне (False), то у повному розгалуженні виконується послідовність команд 2 і після цього виконується команда, наступна за розгалуженням, а у неповному — відразу виконується команда, наступна за розгалуженням.

Yevgenii1423

Відмінності виконання повного і неповного розгалуження: 1) обчислюється значення логічного виразу, якщо це значення істинне (True), то у повному розгалуженні виконується послідовність команд і після цього виконується команда, наступна за розгалуженням, а у неповному — виконується послідовність команд і після цього виконується команда, наступна за розгалуженням; 2) якщо це значення хибне (False), то у повному розгалуженні виконується послідовність команд 2 і після цього виконується команда, наступна за розгалуженням, а у неповному — відразу виконується команда, наступна за розгалуженням.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая - вводит в компьютер с клавиатуры годовые оценки к учеников класса; - подсчитывает и выводит на экран среднюю оценку в классе; - подсчитывает и выводит на экран количество учеников, у которых оценка выше средней.
Ваше имя (никнейм)*
Email*
Комментарий*