Andreevna_Grebenshchikova155
?>

Написать программу с массивом случайных 5 чисел от -50 до 50, если больше нуля - то сложить их, если меньше нуля - вычесть. (сумма и разность)

Информатика

Ответы

Галина-Юлия1292
Скорее всего так:
const n=5; 
var a:array[1..n] of integer;
i,s,r:integer; 
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
 begin
 a[i]:=random(101)-50;
 write(a[i]:4);
 end;
writeln;
s:=0; r:=0;
for i:=1 to n do
 if a[i]>0 then s:=s+a[i] else r:=r-a[i];
writeln('s = ',s,' r = ',r);
end.

Пример:
Массив A:
29 32 -48 -42 11
s = 72 r = 90
lugowskayatania2017
#include <iostream>
#include <stdlib.h>
#include <ctime>

using namespace std;

int main() {
    int a[5], p = 0, n = 0;
    srand ( time(NULL) ); 
    for (int i = 0 ; i < 5 ; i++) {
        a[i]=rand()%100-50;
        cout << a[i] << ' ';
        if(a[i] > 0) p+=a[i];
        else n-=a[i];
    }
    cout << endl << p << ' ' << n << endl; 
}
slonikkristi69
Program Test;

Var
a1, a2, d, k, max, tmp: integer;
sum: real;
rule: boolean;

Begin

Writeln('Введите а1 и а2');
Readl(a1, a2);

k := 2;
d := a2 - a1;
rule := true;

while (rule = true) do
begin
k := k + 1;
tmp := a1 + k * d;

if (tmp < 50) then
max := tmp

else
rule := false;

end;

sum := (a1 + max) / 2 * k;

Writeln();
Writeln('Сумма = ', sum);

End.


Программа будет работать только для арифметических прогрессий, например, таких, как последовательность из задания. Вводить нужно 2 целых числа (первые два члена прогрессии) через пробел (в вашем случае 4 и 7)
nalich8524
Program Test;

Var
a1, a2, d, k, max, tmp: integer;
sum: real;
rule: boolean;

Begin

Writeln('Введите а1 и а2');
Readl(a1, a2);

k := 2;
d := a2 - a1;
rule := true;

while (rule = true) do
begin
k := k + 1;
tmp := a1 + k * d;

if (tmp < 50) then
max := tmp

else
rule := false;

end;

sum := (a1 + max) / 2 * k;

Writeln();
Writeln('Сумма = ', sum);

End.


Программа будет работать только для арифметических прогрессий, например, таких, как последовательность из задания. Вводить нужно 2 целых числа (первые два члена прогрессии) через пробел (в вашем случае 4 и 7)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу с массивом случайных 5 чисел от -50 до 50, если больше нуля - то сложить их, если меньше нуля - вычесть. (сумма и разность)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

suturinavaleriya51
Zolotnik974620
Skvik71
madina27821667
Strelkov-Roman1263
pk199888
ПетросовичЗаславский
strager338
nadyatsoi
NarekAlekseevich779
ksyrika
kyzua2475
Nadezhda
Tane4ka2110
Щуплова Александр