irkm8
?>

Паскаль! ! провода дано n отрезков провода длиной l1, l2, ln сантиметров. требуется с разрезания получить из них k равных отрезков как можно большей длины, выражающейся целым числом сантиметров. если нельзя получить k отрезков длиной даже 1 см, вывести 0. ограничения: 1 < = n < = 10 000, 1 < = k < = 10 000, 100 < = li < = 10 000 000, все числа целые. входные данные в первой строке находятся числа n и к. в следующих n строках - l1, l2, ln, по одному числу в строке. выходные данные вывести одно число - полученную длину отрезков.

Информатика

Ответы

Chutaeva381
// PascalABC.NET 3.2, сборка 1379 от 21.01.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var ЕстьКусков,НадоКусков:integer;
  Readln(ЕстьКусков,НадоКусков);
  var Длины:=ReadArrInteger(ЕстьКусков);
  var ОбщаяДлина:=Длины.Sum;
  if НадоКусков>ОбщаяДлина then Writeln(0)
  else begin
    var ДлинаКуска:=ОбщаяДлина div НадоКусков;
    repeat
      if Длины.Select(Кусок->Кусок div ДлинаКуска).Sum >=НадоКусков then break
      else ДлинаКуска-=1;
    until false;
    writeln(ДлинаКуска)
    end
end.

Пример
4 11
802 743 457 539
200
mmreznichenko
Решение в прикрепленном файле.

Ввод -вывод
5 12
6
7
8
9
10
длина отрезка: 3
vladimirdoguzov

3D моделирование часто применяется  при создании новых видов продукции, или когда имеющееся двухмерное изображение предмета является недостаточным для реализации поставленных целей.

Трехмерная графика незаменима и для презентации будущего изделия. Для того, чтобы приступить к производству необходимо нарисовать, а затем создать 3d-модель объекта. На основе 3д-модели, с технологий быстрого изготовления прототипа (3d печать, фрезеровка, литье силиконовых форм и т.д.), создается реалистичная модель  будущего изделия.

Особенно широко 3d моделирование используется компаниями, которые занимаются архитектурой, строительством, дизайном интерьеров и ландшафтным дизайном. Сейчас уже редко кто обходится без 3d визуализации в подобных случаях.

3D-моделирование также бывает необходимым в случаях, когда необходимо смоделировать объект для предварительного анализа или отсутствует доступ к реальным объектам.

Широкое распространение 3d моделирование получило в ювелирном деле, когда бедующие украшения предварительно моделируются в 3D на экране монитора.

3D-модели и их визуализация часто применяются в презентациях, интернет рекламе, телерекламе и других видах коммерческой деятельности частных лиц и предприятий с различной формой собственности.

РубенШафетдинов

На C++:

#include <iostream>

#include <cmath>

using namespace std;

int main() {

setlocale(0, "RU");

int a, b, c;

cout << "Введите коэффициенты уравнения: ";

cin >> a >> b >> c;

cout << "D = b^2 - 4 * a * c\n";

cout << "D = " << b * b << " - " << 4 * a * c << endl;

double D = (b * b) - (4 * a * c);

cout << "D = " << D << endl;

int d = sqrt(D);

cout << "vD = " << endl << endl;

 

 

a *= 2;

int x1 = (-b - d) / a;

int x2 = (-b + d) / a;

cout << "x1 = (-b - vD) / 2a = " << x1 << endl;

cout << "x2 = (-b + vD) / 2a = " << x2;

return 0;

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Паскаль! ! провода дано n отрезков провода длиной l1, l2, ln сантиметров. требуется с разрезания получить из них k равных отрезков как можно большей длины, выражающейся целым числом сантиметров. если нельзя получить k отрезков длиной даже 1 см, вывести 0. ограничения: 1 < = n < = 10 000, 1 < = k < = 10 000, 100 < = li < = 10 000 000, все числа целые. входные данные в первой строке находятся числа n и к. в следующих n строках - l1, l2, ln, по одному числу в строке. выходные данные вывести одно число - полученную длину отрезков.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

nastya3213868
warlordkolomna
peresvetoff100015
kyrtlab39
Елена-Олег
mekap22044
Caragyant
Сергеевич1396
maria
Спиридонова
coffeenik20233
Щербаков33
olg14855767
keshka12719