// pascalabc.net 3.1, сборка 1250 от 28.05.2016 begin var x: =arrrandom(readinteger('n='),1,99); writeln('исходная последовательность'); x.println; var a: =readinteger('a='); var i: =x.findindex(e-> e=a); if i< 0 then writeln(-1) else if i< x.length-1 then writeln(x[i+1: ].sum) else writeln(0) end. тестовое решение: n= 15 исходная последовательность 26 50 92 84 30 60 9 95 46 47 59 54 97 11 36 a= 59 198
КристинаАлександр
22.01.2023
Const n=5; var a: array[1..n,1..n] of integer; b: array[1..n] of integer; i,j,max,min,s: integer; begin randomize; writeln('исходный массив: '); for i: =1 to n do begin for j: =1 to n do begin a[i,j]: =random(21); write(a[i,j]: 4); end; writeln; end; max: =a[1,n]; for i: =2 to n do if a[i,n-i+1]> max then max: =a[i,n-i+1]; writeln('1. max = ',max); for i: =1 to n do begin min: =a[i,1]; for j: =2 to n do if a[i,j]< min then min: =a[i,j]; b[i]: =min; end; s: =0; writeln('2. массив b'); for i: =1 to n do begin write(b[i]: 4); s: =s+b[i]; end; writeln; writeln('3. среднее = ',s/n); for i: =1 to n do if b[i]> s/n then write(b[i]: 4); writeln; end. пример: исходный массив: 10 19 15 17 10 12 12 10 1 5 17 8 8 14 15 12 11 8 0 13 2 2 4 10 6 1. max = 11 2. массив b 10 1 8 0 2 3. среднее = 4.2 10 8
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Составить программу в pascal, которая вводит трехзначное число и выводит число-перевертыш (пример 123-> 321)
program ssd;
uses crt,graph;
var a,a1,a2,a3: integer;
begin
clrscr;
writeln('введите трехзначное число');
readln(a);
a1: = a mod 10;
a2: =(a div 10) mod 10;
a3: = a div 100;
writeln(' ',a1,a2,a3);
readkey;
end.