Zolotnik974620
?>

Задано натуральное число n. напишите программу, которая выведет на экран все числа: сначала число n, а затем числа от 1 до n - 1. входные данные вводится одно натуральное число, не превосходящее 1000 выходные данные выведите n - 1 натуральное число. числа должны быть разделены пробелами. знаю решение, но не могу понять как вывести сначала 5, всё перепробовал, но 5 всегда в конце

Информатика

Ответы

leeka152522
 var i,N:integer;
begin 
веедите натуральное число не превосходящее 1000'); 
readln(N); 
writeln('Входное число=',N); 
for i:=0 to (N-1) do write(i,' ');
 end.

Пример работы: 
веедите натуральное число не превосходящее 1000
5
Входное число=5
0 1 2 3 4 
P.S.Если в условии от 1-го, а не от нуля, for i:=0 to (N-1) do write(i,' '); замени на for i:=1 to (N-1) do write(i,' ');

Лишняя информация, если тебе не нравится информатика: на сколько я понял, ты не мог понять как вывести сначала число 5. В моей программе это делает оператор writeln(N); Именно Writeln, а не Write. Почему? Потому что writeln произошло от слова line - линия, оно занимает целую строку. А Write мастит все в одну строку. Если нужно будет что-то рассказать и это будет в моих силах, я с радостью любому желающему.
Виталий
Запись файла любого типа и использование диска на компьютере с Windows XP или более поздней версией.Диск: CD-R, CD-RW, DVD-R, DVD-R DL, DVD+R, DVD+R DL, DVD-RW, DVD+RW или DVD-RAMФормат:‌ файловая система LFSЗапись файла любого типа и использование диска на любом компьютере, где могут быть установлены версии Windows, более ранние, чем Windows XP.Диск: CD-R, CD-RW, DVD-R, DVD-R DL, DVD+R, DVD+R DL, DVD-RW, DVD+RW или DVD-RAMФормат: MasteredЗапись файла любого типа и использование диска на компьютере с Windows Vista или более поздней версией.Диск: CD-R, CD-RW, DVD-R, DVD-R DL, DVD+R, DVD+R DL, DVD-RW, DVD+RW, DVD-RAM, BD-R или BD-REФормат:‌ файловая система LFS или MasteredЗапись музыки или изображений и использование диска на некоторых обычных проигрывателях компакт-дисков, DVD-дисков или дисков Blu-ray, воспроизводящих МР3-файлы и цифровые изображения.Диск: CD-R, CD-RW, DVD-R, DVD+R, DVD-RW или DVD+RWФормат: MasteredЗапись музыки и изображений и использование диска на любом компьютере, где могут быть установлены версии Windows, более ранние, чем Windows XP.Диск: CD-R, CD-RW, DVD-R, DVD+R, DVD-RW или DVD+RWФормат: MasteredВозможность многократного добавления и стирания одного или множества файлов (как в случае использования USB-устройства флэш-памяти) и использование диска на компьютерах с Windows XP или более поздней версией.Диск: CD-R, CD-RW, DVD-R, DVD-R DL, DVD+R, DVD+R DL, DVD-RW, DVD+RW или DVD-RAMФормат: LFSВозможность многократного добавления и стирания одного или множества файлов (как в случае использования USB-устройства флэш-памяти) и использование диска на компьютерах с Windows 7.Диск: CD-R, CD-RW, DVD-R, DVD-R DL, DVD+R, DVD+R DL, DVD-RW, DVD+RW, DVD-RAM, BD-R или BD-REФормат: файловая система LFSНахождение диска в устройстве записи компьютера, копирование на него файлов, например, для резервного храненияДиск: CD-R, CD-RW, DVD-R, DVD-R DL, DVD+R, DVD+R DL, DVD-RW, DVD+RW, DVD-RAM, BD-R или BD-REФормат: файловая система LFS
AndrukhovichKonovalov

Pascal

const  

  n=25;

var

 a:array[1..n] of integer;

 i, s0, s1, s2, s3 : integer;

begin

 randomize;

 s0:=0; s1:=0; s2:=0; s3:=0;

 for i:=1 to N do begin

   a[i]:=random(5)+1; (*если хотим ввести случайные оценки*)

//    readln(a[i]);  (*если хотим ввести оценки сами*)

   s0:=s0+a[i];

   case a[i] of

     4,5: inc(s1);

     3: inc(s2);

     1,2: inc(s3);

   end;

 end;

 writeln(a);

 writeln('Средний бал =', s0/n);

 writeln('Кол-во 4 и 5 =', s1);

 writeln('Кол-во 3 =', s2);

 writeln('Кол-во 2 и 1 =', s3);

end.


На языке Паскаль составить программу для решения задач. класс в составе 25 чел. сдал экзамен по мате

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Задано натуральное число n. напишите программу, которая выведет на экран все числа: сначала число n, а затем числа от 1 до n - 1. входные данные вводится одно натуральное число, не превосходящее 1000 выходные данные выведите n - 1 натуральное число. числа должны быть разделены пробелами. знаю решение, но не могу понять как вывести сначала 5, всё перепробовал, но 5 всегда в конце
Ваше имя (никнейм)*
Email*
Комментарий*