Владислав-Аветисян217
?>

Составить программу в паскале , которая в массиве из десяти целых чисел считает среднее арифметическое отрицательных.

Информатика

Ответы

tatakypzova
Const n=10; 
var a:array[1..n] of integer;
i,s,k:integer; 
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
 begin
 a[i]:=random(51)-25;
 write(a[i]:4);
 end;
writeln;
s:=0; k:=0;
for i:=1 to n do
 if a[i]<0 then begin s:=s+a[i]; k:=k+1; end;
writeln('s = ',s,' k = ',k);
if k>0
 then writeln('Среднее арифметическое отрицательных = ',s/k)
 else writeln('Отрицательных нет');
end.

Пример:
Массив A:
 -11  11  13   9 -11  -2  18 -18   3 -14
s = -56 k = 5
Среднее арифметическое отрицательных = -11.2
ghjcnjtyjn64
// PascalABC.NET 3.2, сборка 1379 от 21.01.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadArrInteger('Вводите:',10);
  Writeln('Ср.арифм. отрицательных чисел ',a.Where(x->x<0).Average)
end.

Пример
Вводите: 5 -3 2 8 11 21 -42 16 0 5
Ср.арифм. отрицательных чисел -22.5
borodin
1) Как представлено число 8310 в двоичной системе счисления?
В этом вопросе нет ни одного числа двоичного кода. В двоичном коде будет: 10000001110110
2) Дано: , . Какое из чисел С, записанных в двоичной системе счисления, удовлетворяет неравенству ? Я думаю, что вопрос звучал так: Дано: a=222 8 , b=94 Какое из чисел С, записанных в двоичной системе счисления, удовлетворяет неравенству?ответ:2)  С = 250(8сч) удоволетворяет неравенству а=247 меньше С=250 и b= 251 больше С=250.
3) Даны 4 целых числа, записанные в двоичной системе...
ответ: все четыре числа меньше чем 396
4) Укажите через запятую в порядке возрастания все основания систем счисления, в которых запись числа 39 оканчивается на 3.
ответ: 4, 6, 9, 12, 18, 36
5) Запись числа 30 в некоторой системе счисления выглядит так: 110N. Найдите основание системы счисления N.
1)30=1*N^{2}+*N^{1}+*N^{0}
N^{2}+N-30=0
(N+6)(N-5)=0 N\geq=5
2)2B_{16}=2*16+11=43=1*N^{1}+1*N^{0}
N^{2}+N-42=0
(N+7)(N-6)=^{0}N \geq 0 N=6
6) Решить уравнение: где????????????????
7) Сколько единиц в двоичной записи числа 42016 + 22018 – 6?
Я не смог решить
8) Значение арифметического выражения: 274 – 95 + 38 – 25 записали в системе счисления с основанием 3. Сколько цифр «2» содержится в этой записи?
Я не смог решить
TatyanaVladimirovich

115₁₀ = 1110011₂

а) 1001111₂ = 79₁₀

б) 356₈ = 238₁₀

в) 24С₁₆ = 588₁₀

543₈ → 355₁₀ → 163₁₆

Объяснение:

115 / 2 = 57 + остаток 1

57 / 2 = 28 + остаток 1

28 / 2 = 14 + остаток 0

14 / 2 = 7 + остаток 0

7 / 2 = 3 + остаток 1

3 / 2 = 1 + остаток 1

1 / 2 = 0 + остаток 1

записываем остатки снизу вверх

115₁₀ = 1110011₂

а) 1001111₂ = 1 * 2⁶ + 0 * 2⁵ + 0 * 2⁴ + 1 * 2³ + 1 * 2² + 1 * 2¹ + 1 * 2⁰ = 64 + 8 + 4 + 2 + 1 = 79₁₀

б) 356₈ = 3 * 8² + 5 * 8¹ + 6 * 8⁰ = 3 * 64 + 5 * 8 + 6 * 1 = 192 + 40 + 6 = 238₁₀

в) 24С₁₆ = 2 * 16² + 4 * 16¹ + С * 16⁰ = 2 * 256 + 4 * 16 + 12 * 1 = 512 + 64 + 12 = 588₁₀

В качестве цифр шестнадцатеричной системы счисления обычно используются цифры от 0 до 9 и латинские буквы от A до F.

A = 10₁₀     В = 11₁₀   С = 12₁₀   D = 13₁₀   Е = 14₁₀   F = 15₁₀

543₈ = 5 * 8² + 4 * 8¹ + 3 + 8⁰ = 5 * 64 + 4 * 8 + 3 * 1 = 320 + 32 + 3 = 355₁₀

355 / 16 = 22 + остаток 3

22 / 16 = 1 + остаток 6

1 / 16 = 0 + остаток 1

записываем остатки снизу вверх

355₁₀ = 163₁₆

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу в паскале , которая в массиве из десяти целых чисел считает среднее арифметическое отрицательных.
Ваше имя (никнейм)*
Email*
Комментарий*