sn009
?>

На берегу реки сидят жуки и пауки, у которых вместе n ног. у каждого жука по 6 ног, у паука по 8 ног. известно, что ног у всех жуков в k раз меньше, чем у всех пауков.напишите программу, которая определяет, сколько всего жуков и пауков сидит на берегу.это все в pascale.

Информатика

Ответы

opal19575
//прога на Pascal`e
var
N : uint64;
K : real;
begin
write ('Введите кол-во ног: ');
readln (n);
write ('Введите отношение ног жуков к паукам: ');
readln (k);

if trunc (n/(k+1)) <> n/(k+1) then write ('Неверное условие!')
else 
if trunc (n/(k+1)) mod 8 <> 0 then write ('Неверное условие!')
else write ('Жуков: ', n/(k+1)*k/6, ', пауков: ', n/(k+1)/8);

end.
Головин662
Рассуждение №1
а) Пусть в первом высказывании истинно первое утверждение и Вася  - первый. Тогда утверждение, что Юра второй - ложно, следовательно Юра не второй.
б) Если Вася первый, то в четвертом высказывании утверждение о том, что Гриша первый ложно. Следовательно Гриша не первый, а Юра - четвертый.
в) Если Юра четвертый, то в пятом высказывании ложно утверждение, что Иван второй.
г) Если Иван не второй, то в третьем высказывании истинно утверждение, что Гриша четвертый. Но в б) мы пришли к выводу, что четвертый Юра, а двое не могут быть одновременно четвертыми. Тогда утверждение а) о том, что Вася первый - ложно и надо идти другим путем.

Рассуждение №2
а) Пусть в первом высказывании истинно второе утверждение и Вася  не первый, а Юра - второй.
б) Если Юра второй, то в четвертом высказывании утверждение что Юра четвертый ложно, следовательно, истинно утверждение о том, что Гриша первый.
в) Если Гриша первый, то в третьем высказывании ложно утверждение о том, что Гриша четвертый, но тогда истинно утверждение, что Иван второй.
г) Утверждение, что Иван второй, противоречит выводу а), где принимается, что второй Юра. Следовательно, допущение что Юра второй приводит нас к противоречию.

Итог: мы получаем противоречие, полагая, что любое из двух утверждений в высказывании 1 истинно, следовательно, имеются противоречия в условии задачи и она не может быть решена. 
keshka12719
Рассуждение №1
а) Пусть в первом высказывании истинно первое утверждение и Вася  - первый. Тогда утверждение, что Юра второй - ложно, следовательно Юра не второй.
б) Если Вася первый, то в четвертом высказывании утверждение о том, что Гриша первый ложно. Следовательно Гриша не первый, а Юра - четвертый.
в) Если Юра четвертый, то в пятом высказывании ложно утверждение, что Иван второй.
г) Если Иван не второй, то в третьем высказывании истинно утверждение, что Гриша четвертый. Но в б) мы пришли к выводу, что четвертый Юра, а двое не могут быть одновременно четвертыми. Тогда утверждение а) о том, что Вася первый - ложно и надо идти другим путем.

Рассуждение №2
а) Пусть в первом высказывании истинно второе утверждение и Вася  не первый, а Юра - второй.
б) Если Юра второй, то в четвертом высказывании утверждение что Юра четвертый ложно, следовательно, истинно утверждение о том, что Гриша первый.
в) Если Гриша первый, то в третьем высказывании ложно утверждение о том, что Гриша четвертый, но тогда истинно утверждение, что Иван второй.
г) Утверждение, что Иван второй, противоречит выводу а), где принимается, что второй Юра. Следовательно, допущение что Юра второй приводит нас к противоречию.

Итог: мы получаем противоречие, полагая, что любое из двух утверждений в высказывании 1 истинно, следовательно, имеются противоречия в условии задачи и она не может быть решена. 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

На берегу реки сидят жуки и пауки, у которых вместе n ног. у каждого жука по 6 ног, у паука по 8 ног. известно, что ног у всех жуков в k раз меньше, чем у всех пауков.напишите программу, которая определяет, сколько всего жуков и пауков сидит на берегу.это все в pascale.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Aleksandr72
vasiliyglukhov
intermar2000
extremhunter
Ольга
Самохвалова-Геннадьевна
anton
vifslafes
АлексейГагиковна1774
Yelena Dilyara
AOS2015
виталийВячеславович
Елена
afilippov3321
saniopt