yrgenson2011801
?>

Информатика. 1)написать программу, которая запрашивает одно число-количество учащихся в классе, и выводит минимальное количество парт, необходимое для рассадки по 2 человека. 2)написать программу, которая запрашивает одно натуральное пятизначное число, и выводит его третью цифру. 3)для покраски стен и пола комнаты шириной а метров, длинной b метров и высотой с метров(а, b и с-целые числа) необходимое закупить краску. известно, что одной банки крачки хватает на покраску k кв.метров поверхности.найти минимальное необходимое количество банок краски. прогорамма должна получать на выход четыре числа-ширина, высота, длина и количество кв.метров, на которое хватает одной банки краски, и выводит необходимое количество банок.

Информатика

Ответы

ashantik
{1}
var
n : longint;
begin
readln (n);
write ( (n div 2) + (n mod 2));
end.

{2}
var
n : longint;
begin
repeat
readln (n);
until (n in [10000..100000]) and (abs(n) = n);
write ( ((n mod 1000) - (n mod 100)) div 100 );
end.

{3}
var
a, b, c, sqrM, sum : longint;
begin
readln (a, b, c, sqrM);
sum:=(((a+b)*c)*2 + a*b) div sqrM;
if a+b)*c)*2 + a*b) mod sqrM)<>0 then inc(sum);
write (sum);
end.
afomin63
Const n=20;
var a:array[1..n] of integer;
i,i1,i2,x:integer;
begin
Randomize;
a[1]:=random(10);
write(a[1],' ');
for i:=2 to n do
 begin
 a[i]:=a[i-1]+random(10);
 write(a[i],' ');
 end;
writeln;
write('x = '); readln(x);
i1:=1; i2:=n;
repeat
i:=(i1+i2) div 2;
if a[i]<x then i1:=(i1+i2) div 2+1;
if a[i]>x then i2:=(i1+i2) div 2-1;
until (a[i]=x)or(i1>i2);
if a[i]=x then 
 begin
 writeln('Искомый(ые) номер(а) элемента(ов):');
 while (i>0)and(a[i]=x) do i:=i-1;
 i:=i+1;
 while (i<=n)and(a[i]=x) do begin write(i,' '); i:=i+1; end;
 end
 else writeln('Элемент не найден');
writeln;
end.

Пример:
5 6 14 15 15 22 30 36 45 45 50 56 60 64 67 76 84 92 99 101 
x = 15
Искомый(ые) номер(а) элемента(ов):
4 5 
catmos
Фишинг (от англ. fishing - рыбная ловля, выуживание) - вид интернет-мошенничества, цель которого - получить данные, содержащиеся на вашей пластиковой карте.<br /><br />Злоумышленники рассылают электронные письма от имени банков или платежных систем. Пользователю предлагается зайти на сайт, который является точной копией настоящего сайта банка, где можно увидеть объявления, например, об изменении системы безопасности банка. Для дальнейшей возможности использовать свою пластиковую карту вас просят указать пин-код и данные, содержащиеся на карте. Впоследствии эти данные используются для изготовления поддельной пластиковой карты и обналичивания денежных средств, содержащихся на вашем счете. Оставив свои данные, вы фактически преподносите мошенникам деньги на блюдечке.<br /><br />Одной из разновидностью данного вида правонарушения являются звонки на сотовые телефоны граждан якобы от представителей банка с погасить задолженность по кредиту. Когда гражданин сообщает, что никакого кредита не брал, ему предлагается уточнить данные, содержащиеся на пластиковой карте. Этого уже достаточно для покупки товаров в Интернет-магазинах.<br /><br />Следует помнить, что банки и платежные системы никогда не присылают писем и не звонят на телефоны граждан с предоставить<br />свои данные. Если такая ситуация произойдет, вас попросят приехать в банк лично.<br /><br />

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Информатика. 1)написать программу, которая запрашивает одно число-количество учащихся в классе, и выводит минимальное количество парт, необходимое для рассадки по 2 человека. 2)написать программу, которая запрашивает одно натуральное пятизначное число, и выводит его третью цифру. 3)для покраски стен и пола комнаты шириной а метров, длинной b метров и высотой с метров(а, b и с-целые числа) необходимое закупить краску. известно, что одной банки крачки хватает на покраску k кв.метров поверхности.найти минимальное необходимое количество банок краски. прогорамма должна получать на выход четыре числа-ширина, высота, длина и количество кв.метров, на которое хватает одной банки краски, и выводит необходимое количество банок.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

MonashevFesenko1483
krutikovas
dvpered
Nikolaevich-Svetlana388
Владимирович_Ралина
Sakmarov
hotel-info
ninaandreeva3179
Bologova Golovach1989
Захаров-Иванович
spodobnyi
sev-94428
Державина
shalunovroman
kapriz1999