Феофанов_Никита1067
?>

Напишите программу на языке паскаль, которая в последовательности целых чисел определяет количество четных чисел кратных 3.программа получает на выход целые числа. количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0-признак окончания ввода, не входит в последовательность количество чисел не превышает 20. введенные числа [-30; 30]. программа должна вывести одно число: количество четных чисел, кратных 3. буду признательна!

Информатика

Ответы

mirsanm26249
Program n1;
const n=20;
var a: array [1..n] of integer;
i,k: integer;
begin
k:=0;
for i:=1 to n do
begin
write('введите ',i,' число: ');
readln(a[i]);
if (a[i]=0) or (a[i]<=-30) or (a[i]>=30) then break;
if (a[i] mod 2=0) and (a[i] mod 3=0) then k:=k+1;
end;
writeln('количество: ',k);
end.
laktionova-natal

// PascalABC.NET 3.6.3

uses School;

function Divizors(n: integer): List<integer>;

begin

 var L := new List<integer>;

 L.Add(1);

 L.Add(n);

 if n > 3 then

   begin

   var k := 2;

   while (k * k <= n) and (k < 46341) do

   begin

     if n mod k = 0 then

     begin

       var t := n div k;

       L.Add(k);

       if k < t then L.Add(t)

       else break

     end;  

     Inc(k)

   end;

   L.Sort;

 end;

 Result := L

end;

begin

 // 1

 if ReadInteger.IsPrime then Println('YES')

 else Println('NO');

 // 2

 ReadInteger.Factorize.First.Println;

 // 3

 var a := Divizors(ReadInteger);

 Print(a.Count, a.Sum)

end.

masum-2011687

<!DOCTYPE html>

<html>

<head>

<meta charset="UTF-8">

<title>mytest</title>

</head>

<body>

<table border="2">

<tr>

<th>Страна </th>

<th>Столица </th>

<th>Официальный язык </th>

<th>Денежная единица </th>

</tr>

<tr>

<td>Италия </td>

<td>Рим </td>

<td>итальянский </td>

<td>евро </td>

</tr>

Тут должно быть так же как и во втором

Великобритания

Английский

Англия

Норвегия

Осло

норвежский

крона

</body>

</html>

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу на языке паскаль, которая в последовательности целых чисел определяет количество четных чисел кратных 3.программа получает на выход целые числа. количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0-признак окончания ввода, не входит в последовательность количество чисел не превышает 20. введенные числа [-30; 30]. программа должна вывести одно число: количество четных чисел, кратных 3. буду признательна!
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

yulialoveinthelow2010
oshemkov579
de1979nis
Plotnikovangav
mmi15
nunabat457
Pashinov
Dmitrievich1871
Faed_Arakcheeva
gullieta
Dmitrii836
Svetlana ALLA
info126
cometa94558
Vik1744184